2

I need to configure xfreerdp to be set as 15 bpp every time is launched, without the need of use the

# xfreerdp --sec rdp -a 15 --no-bmp-cache srvaddr

Opening the config.txt of xfreerdp, shows me the IP of the server, and if I add /bpp:15 or -a 15, the program won't launch.

What is the correct syntax for this config file?

1

Sad to say there is no such option as storing settings in a config file with xfreerdp.
What you could do instead is use a scripting language and wrap xfreerdp by adding this functionality support.

For new cli versions of xfreerdp:

xfreerdp /bpp:15 ...

For deprecated cli versions:

xfreerdp -a 15 ...
  • Ow... sad to ear that, thank you my friend – kek Apr 25 '16 at 9:21
  • If I change system depth, will it change the rdp conecction bpp? – kek Apr 25 '16 at 9:32
  • 1
    It should as the default value is the depth of the root window. Keep also in mind that the color depth may also be limited by the server configuration. – marc Apr 25 '16 at 10:03
0

I like to use a combination of aliases and functions in .bashrc:

export RDP_OPTS="/d:... /u:... /bpp:32 +compression +fonts +aero +home-drive +clipboard"

rdp() {
    xfreerdp $RDP_OPTS /h:1050 /w:1680 /v:$1
}

rdp1() {
    xfreerdp $RDP_OPTS /f /v:$1
}

rdp2() {
    xfreerdp $RDP_OPTS /f /multimon /v:$1
}

This gives me three handy commands which take a server name as their only parameter:

  • rdp - rdp session in a window
  • rdp1 - full-screen rdp session (1 monitor)
  • rdp2 - full-screen rdp session (2 monitors)

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.