I am attempting to connect a TI-89 graphing calculator as a serial terminal to a Raspberry Pi running the latest version of Raspbian. The calculator is emulating a PL2303 serial adapter at /dev/ttyUSB0 and is able to send and receive text from minicom running on the Pi. However, when trying to start a command-line on the device there is no prompt to login. The Pi is using systemd and when I run systemctl start serial-getty@ttyUSB0.service it executes without error.

Running systemctl status serial-getty@ttyUSB0.service returns the following:

● serial-getty@ttyUSB0.service - Serial Getty on ttyUSB0
   Loaded: loaded (/lib/systemd/system/serial-getty@.service; disabled)
   Active: active (running) since Mon 2016-04-25 01:30:27 UTC; 9s ago
     Docs: man:agetty(8)
 Main PID: 6523 (agetty)
   CGroup: /system.slice/system-serial\x2dgetty.slice/serial-    getty@ttyUSB0.service
           └─6523 /sbin/agetty --keep-baud 115200 38400 9600 ttyUSB0 vt102

Apr 25 01:30:27 calcpi systemd[1]: Started Serial Getty on ttyUSB0.

The calculator at this point receives two carriage returns and nothing more. Tying to send any commands from the calculator to the Pi has no response, including the ASCII control codes: ACK, SYN, DC1, and ENQ. I have been looking for information in regards to the protocol used here in case there is supposed to be a response on the calculator side before the login prompt with no luck. Any suggestions on how to get a login prompt to appear would be greatly appreciated.

Update: When trying to start the command-line using just agetty rather than systemd I was able to pass an initial string as an argument and the first character of the string is displayed on the calculator. So for example sudo agetty -I "Hello world" -L 9600 ttyUSB0 vt100 displays H on the calculator.

  • Perhaps you need to enable the service as well. – Ralph Rönnquist Apr 25 '16 at 4:36
  • Thanks, it seems enable just sets the service to run on boot and didn't cause a login prompt. – Gavinator98 Apr 25 '16 at 5:15
  • And if the line ends with \n? The normal greeting /etc/issue (on my machine) is two lines ending with newlines. – Ralph Rönnquist Apr 25 '16 at 5:35
  • I do remember as a student that we had to use low speeds to transfer reliably data from a calculator to another via RS-232...also in my Lamobo R1 (raspberry compatible), I had to setup the connection in the kernel arguments to use my PL2303; console=ttyS1,115200n8 – Rui F Ribeiro Apr 25 '16 at 8:11
  • Looking around online it seems that the usb port on the calculator is 4-5 kbit/s so that may have been an issue but setting the baud rate to 1200 still has the same result. Even if the greeting is terminated with a \n – Gavinator98 Apr 25 '16 at 21:45

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.