In an effort to protect my personal files in my home directory, I am trying to run certain applications as an alternate user, but under the same graphical environment.

I have enabled X permissions by running the command: xhost +si:localuser:$ALTUSER

However, when I run a program like iceweasel (firefox) as the alternate user, there are a bunch of error messages in the console like this one:

(iceweasel:10304): dconf-CRITICAL **: unable to create directory '/run/user/1000/dconf': Permission denied. dconf will not work properly.

And a popup appears when the application starts which says:

An error occurred while loading or saving configuration information for iceweasel. Some of your configuration settings may not work properly.

In the first error message dconf is trying to create a folder called /run/user/1000/dconf but that's my main user (1000), not the id of the alternate user that is running the program (1001).

Is there a way to make dconf work correctly in this scenario?

1 Answer 1


I needed to add a dash when switching users in the console. So su - $ALTUSER instead of su $ALTUSER. The dash - is an alias for the -login option of su.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .