14

When GNOME Keyring, needs a password to add an SSH key to the agent, it pops up a system modal prompt to get the password from you. I use KeePass, so this means that if I forgot to copy the password before the SSH attempt, I'm out of luck because of the system modal behaviour, and have to fail the connection.

See also this GNOME bug. As of GNOME 3.18, the workaround provided there isn't valid.

Since I would prefer to not muck around in GNOME's source code: is there any way, via configuration, to make the system modal prompts not be system modal?

4
  • if you use keepassxc you can use autocomplete feature
    – intika
    Commented Jun 1, 2019 at 13:13
  • 2
    What about disabling the "Attach modal dialogs" option under the "Window" section in gnome-tweaks?
    – istepaniuk
    Commented Jun 4, 2019 at 12:47
  • @istepaniuk that is about model dialogs that attach to applications, like print dialogs in wordpricessor, so that print dialogs won't be hidden behind the application. the OP is talking about the gnome-shell dialogs.
    – toppk
    Commented Sep 4, 2022 at 23:14
  • I don't know of a way. As a workaround, you could switch to kde wallet. it's all the same standards. The workaround I use is just to unlock the keyring on login, so I never have to see the dialog box. Since I have autologin enabled, I actually lock the screen on login, so when I unlock all my applications are already started, and the keyring is open.
    – toppk
    Commented Sep 4, 2022 at 23:43

1 Answer 1

0

Since it's just GNOME's PAM authentication method, you could install an alternative GUI PAM like XFCE's and use that. Just set up a start job (an auto start .desktop file) to gun the gnome implementation and launch the desired one.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .