3

I have tried to install the library on both 14.04 and 15.10. Every time I type in convert -version the delegates do not contain jp2000. I have installed libopenjpeg-dev and libjpeg-dev

I have tried:

  • Installing dependencies beforehand, then installing ImageMagick
  • Installing dependencies after installing ImageMagick

But no cigar. Any suggestions?

  • I'm not sure what you are trying to do, but what is a test to determine whether ImageMagick actually as jp2000 support, or whatever it is? – Faheem Mitha Apr 23 '16 at 17:20
  • As per this top Google search result what are the contents of your corresponding delegates.xml file? The jpg libraries may not be configured to update that file, if that's what needs to happen. – Jeff Schaller Apr 23 '16 at 17:23
  • @FaheemMitha Normally, you can do "convert -version", it'll show all available delegates. – Rizky Fakkel Apr 23 '16 at 19:26
-1

Gimp opens jp2 files and you can read write and edit. Use version from ppa:otto-kesselgulasch/gimp. This also gives you latest Gmic also.

I am using Gimp to print my own copies of some C19th text books. Project Gutenburg Scans for example.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.