2

I have Jessie Debian 8.4

I installed dropbox, but the icon in the systray is not present.

How can I put it?

Show this :|

3

I am using Debian Jessie 8.5 (KDE 4.14.2), but had this problem since 8.0. I was lucky to find this workaround.

Just create a script like this in ~/.kde/Autostart:

#!/bin/bash

dropbox stop && dbus-launch dropbox start

I am not exactly sure why this works so if anyone can explain, it would be much appreciated.

If that doesn't do it, you can just append the last line to ~/.profile. That should work reliably.


Update: Thanks to the new information from cipricus the solution now boils down to merely editing the /usr/share/applications/dropbox.desktop. It should be enough to just replace:

Exec=dropbox start

with:

Exec=dbus-launch dropbox start

  • @cipricus This will start Dropbox with the system. -- What does it mean exactly? Why are the GUI options not available when it is started in a different way? – martin-is-my-name Jun 19 '16 at 11:33
  • What I meant was: if you don't want to start the app with the system the script should not be put in ~/.kde/Autostart (odd choice but it happened to be mine). To have the systray icon one still has to run the script (copied in some other location). (Starting with the system is default expected behavior for Dropbox.) -- If I don't want to start it with the system & don't use the script but a different way (the 'normal' manual way, like a launcher), the systray icon (therefore the GUI) will not be visible, while the app will be in fact running (visible in the system monitor ksysguard). – user32012 Jun 19 '16 at 15:19
  • Summing it up: 1. if you need the normal behavior to start the app with the system, just follow the answer; 2. if by chance you want to start the app manually put the script in some other location and run it manually. – user32012 Jun 19 '16 at 15:22
  • 1
    @cipricus Actually, I have one remark on the solution (sorry, I cannot comment on your answer -- not enough rep ¯\_(ツ)_/¯). I found out today that when the 'Start Dropbox at system startup' is checked in Dropbox Settings, on my system, it tends to reset the entry (and automatically adds it, if previously removed) in the Autostart KDE Control Module. So after reboot it is not executed with dbus-launch again. I guess the safest bet would be to uncheck the box in the Dropbox GUI and provide your own script or desktop file. – martin-is-my-name Jun 21 '16 at 7:10
  • 1
    Yes, what happens is that checking the option 'Start Dropbox at system startup' will add Dropbox to the startup list with the command that is set in usr/share/applications/dropbox.desktop. This is the command that is executed anyway, so the manual change indicated at the point 1 of my answer is useless. I will edit my answer. – user32012 Jun 21 '16 at 10:17
1

This is a complementary answer based on the other one.

It seems that in order to fix this problem Dropbox needs to be started with the command

dbus-launch dropbox start

(dropbox stop in the script was needed considering that Dropbox was supposed to be already running)

  • Run "Autostart" in krunner (Alt-Space, type 'Autostart') and remove dropbox from the list, or otherwise edit the Application command to dbus-launch dropbox start.

(The above step may not be needed, but just in case.)

  • Using gedit text editor, run in terminal:

sudo gedit /usr/share/applications/dropbox.desktop

and then replace the line that starts with Exec= like so:

Exec=dbus-launch dropbox start

If Dropbox was removed from the startup list before, start it manually (with a launcher like krunner or with the above mentioned command).


The above is an update to a previous version of this answer:

A comment on the other answer made by the author of the answer mentions the fact that when only the dropbox startup command is edited in the startup list this is reset after reboot and replaced by the command included in /usr/share/applications/dropbox.desktop. So, the command from this .desktop file is the one executed at startup, and therefore is the only change needed.


A similar problem appears in Plasma 5: it can be fixed in the same way. (Tested in Kubuntu 16.04).

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.