2

I am having trouble setting up my wifi configuration persistently.

I have tried both netctl and NetworkManager and both only work after manual setup.

What I find especially weird is that ip link show prints

1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN     mode DEFAULT group default qlen 1
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
2: enp0s31f6: <NO-CARRIER,BROADCAST,MULTICAST,UP> mtu 1500 qdisc     fq_codel state DOWN mode DEFAULT group default qlen 1000
    link/ether 9c:5c:8e:d4:d6:fe brd ff:ff:ff:ff:ff:ff
3: enp0s20f0u13: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc mq state UP mode DORMANT group default qlen 1000
link/ether 38:2c:4a:47:93:11 brd ff:ff:ff:ff:ff:ff

So interface enp0s20f0u13 is UP and used for my current connection, which is going through a Wifi dongle. It is recognized as an Ethernet connection but it shouldn't be.

How I get a connection right now is: after boot I can start systemctl start netctl@<profile> and I have a connection. If I start systemctl start NetworkManager instead then the service starts not complaining about anything but there is no connection and the Gnome applet doesn't show. Settings -> Network shows no info about any Wifi stuff. If I first start netctl, then stop it, then start NetworkManager then Wifi works through NetworkManager, the applet shows and the settings screen shows a Wifi menu.

After having tried lots of stuff I can only hope that the problems arise from this wrong recognition. Any ideas on what to do now?

  • Have you tried manually setting up a connection using wpa_supplicant and ip? If not, that would be my next step in troubleshooting. Sounds like netctl is setting up wpa_supplicant, so that NM can then correctly handle it. – HalosGhost Apr 23 '16 at 16:31
  • NetworkManager should detect your Wi-Fi as such. Sounds like a bug. What is your hardware? – thaller Apr 24 '16 at 21:19
  • wpa_supplicant complained it couldn't init the driver interface or some such. The driver is working perfectly however. netctl enable <profile> successfully auto-connects on boot now. Unless someone points me in the right direction as to actually find out what goes wrong where, I am happy I have Internet on boot right now even though it is not through NetworkManager as I would have preferred, but through netctl. – kunterbunt Apr 26 '16 at 14:12
  • Could be fixed by cgit.freedesktop.org/NetworkManager/NetworkManager/commit/… Impossible to say for sure with the given information. – thaller Apr 30 '16 at 14:39

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.