3

I have a rogue xinput device due to some OS error that sends key press signals even tough nothing is pressed thereby causing screen flickering and the loss of mouse focus.

The device is:

xinput list 8
Video Bus                                   id=8    [slave  keyboard (3)]
This device is disabled
Reporting 1 classes:
    Class originated from: 8. Type: XIKeyClass
    Keycodes supported: 248

How can I permanently disable it so it won't come back after restarting the machine?

OS is: Ubuntu 14.04.4 LTS

1

You create a script to disable it in /etc/X11/xinit/xinitrc.d/

#!/bin/sh
[ -x /usr/bin/xinput ] &&
    xinput disable 'Video Bus'

The scripts in that directory get run automatically when X11 starts.

I suggest /bin/sh because the default scripts in that directory use sh over bash, probably for portability.

  • But this gets reset when you come back from suspend, right? – Martin Ueding Sep 5 '18 at 7:27
  • @MartinUeding I wouldn't expect X to actively enable new devices from suspend, but I admit I've not tried that. – Centimane Sep 5 '18 at 12:06
0

Try to add something like this into your xorg.conf or under xorg.conf.d folder:

Section "InputClass"
   Identifier         "disable broken device"
   MatchIsTouchscreen "on"
   MatchProduct       "full product name from 'xinput list'"
   Option             "Ignore" "on"
EndSection
  • I tried to do it but it doesn't seem to work, this is what i get from xinput list: "xinput -list 8 Video Bus id=8 [slave keyboard (3)] Reporting 1 classes: Class originated from: 8. Type: XIKeyClass Keycodes supported: 248" And this is the content of the file i put at /usr/share/X11/xorg.conf.d/52-disable.conf:"Section "InputClass" Identifier "disable broken device" MatchIsTouchscreen "on" MatchProduct "Video Bus" Option "Ignore" "on" EndSection" – samy May 20 '16 at 15:36
  • One has to put the device name into Identifier and not just have some comment there. Then one does not need the MatchProduct clause any more. – Martin Ueding Sep 5 '18 at 12:21
0

This is not an optimal solution but i found a workaround to insure that the xinput device is disabled for the current user.

I used the gnome-session-properties program to simply execute the line /bin/bash -c "xinput disable 8" on login. This works only for Gnome.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.