1

In VirtualBox 5.0.18 on Windows 10 I'm running the guest:

  • Linux Mint 17.3 Cinnamon 64-bit
  • Cinnamon 2.8.8
  • Linux kernel 3.19.0-32-generic

with 3D acceleration enabled.

Everything was working fine until I updated Linux this morning and started Atom. Atom displayed partially, then showed random glitchy images on the screen, then finally loaded. Then I couldn't close it at all. When pushing ctrl-alt-esc the window would close then restart continuously. I couldn't click anything on the screen.

Now after rebooting the VM I can't click any 'system' areas - e.g. the taskbar, or notifications. I can click only the desktop to open files and things. But I can open the start menu using the Windows key.

I can start & close apps successfully with the keyboard, but not Atom, that still hangs and forces me to reboot. And I need it for work.

I've tried with and without 3D acceleration enabled.

I have all latest Windows updates and graphics drivers.

What else to try? Any idea what is going wrong?

UPDATE

It's not just Atom. Even though other applications (Firefox, LibreOffice) work fine, Visual Studio Code too stays frozen on the screen blocking all other apps when I minimise it:

enter image description here

So now I can't work. Maybe the latest Cinnamon is broken?

UPDATE

It's not just Mint & Cinnamon. Trying to install Visual Studio Code on Ubuntu 16.04 also has the same problems with display, and then later crashing my whole virtual machine.

There are too many variables here to pinpoint the problem - laptop graphics card, Virtualbox, Linux operating system, and the two applications themselves - Atom & VS Code.

Although at home on my old desktop pc Atom runs fine in a Linux Mint VM on Windows 10.

  • Hold on, I think my graphics card may have issues. Windows is doing weird things too. New laptops with faulty cards... – Richard Apr 22 '16 at 10:17
  • Isn't Atom the hackable text editor? Is it possible it wasn't Atom at all but something installed through Atom? If so, have you checked to see if there's anything which might be in the Atom logs? – Peter David Carter Apr 24 '16 at 21:14
  • My VM is totally broken somehow. So on my Windows host I set my graphics driver to be always Nvidia 3d, never the internal Intel driver. Then I created a new Mint Vm, and installed everything one at a time, taking snapshots. Seems to be all ok now. – Richard Apr 25 '16 at 9:17
  • Very similar things happen to me a <em>lot</em>. Let me know as an answer with the full details if it proves to be a stable solution. – Peter David Carter Apr 25 '16 at 9:18
  • Oh no, I spoke to soon. On restart it's broken again. – Richard Apr 25 '16 at 9:48
3

The problem is caused by VBoxGuestAdditions_5.0.18, I believe the graphics driver is broken in it. Try to install VBoxGuestAdditions_5.0.16, that works just fine.

  • Sorry for noob, but how exactly do I do that? – Richard Apr 25 '16 at 16:34
  • 1
    Download the latest VBoxGuestAdditions_5.0.16.iso from download.virtualbox.org/virtualbox/5.0.16/…; mount the iso file to your VM and click 'Run software'. :) – szil Apr 25 '16 at 16:42
  • It worked! Thank you sooo much for helping me here. I was wasting so much time trying to fix something it was crazy. Why does VirtualBox not withdraw version 18, or warn about this problem??? I'm flabbergasted. I just... – Richard Apr 26 '16 at 6:56
0

Try to launch atom with the --disable-gpu option. This worked for me.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.