I have XFCE Debian on an old PowerPC PowerBook G4. When I go to open Synaptic Package Manager, a window pops up asking for my administrative password. I enter the password I normally use for sudo in Terminal, but it doesn't work. I enter nothing, but it doesn't work. I try various other ones - like 'debian', 'synaptic' and 'password', but that doesn't work either. Why doesn't it work?

  • Have you defined a root password on installation? However you can try launching synaptic from terminal with sudo. – enzotib Dec 28 '11 at 17:57
  • @enzotib how do you launch synaptic from terminal? – gadgetmo Dec 28 '11 at 18:00
  • sudo synaptic – enzotib Dec 28 '11 at 18:06
  • You should never launch graphical apps using sudo (or you risk all sorts of issues, notably ~/.Xauthority owner changing and all the issues that come with that). Use gksudo or kdesudo instead. – Chris Down Dec 28 '11 at 20:22

The password you use for sudo is your password. The administrative password is the password of the user root.

If you forgot it, set it up again:

% sudo su -
[sudo] password for *your user*: *enter pwd for your user*
# passwd
*enter new password for user root*
# ^D
  • What if root password was not provided during install (i.e. root user is disabled for logon) and one wants this to stay that way? See here: wiki.debian.org/Root – Davor Josipovic Aug 28 '17 at 21:09

1) I am writing this from Xfce Debian, so I have a little experience.

2) I do not understand any reference above to sudo because Xfce Debian DOES NOT HAVE SUDO INSTALLED BY DEFAULT.You can sudo this and sudo that, but unless you have consciously installed sudo AND added yourself to the sudoers, then all is to no avail.

3) Instead of sudo you need to change from your account to root and you do this with the command: su

Then you could for example run (from root) synaptic.

Find simple instructions about how to add sudo at e.g. http://wiki.dennyhalim.com/debian-minimal-desktop-installation#toc4


Angus is right in a way, but I wouldn't recommend using root, personally. This is what I figured out after a little reading since this was annoying for myself - I already understood what the difference between gksu and gksudo were, but I didn't like it using gksu by default. This is where your trouble lies as well - you were expecting gksudo. There is another app, called gksu-properties that you should run. From this, you set sudo as the default instead of su. This will give you your desired result.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.