4

My installation of libreoffice calc 5.1.1.3 doesn't seem to alter the formatting of hyperlinks, i.e. it looks the same as any other text by default.

When doing searches for how to format said links, I seem to see two advices reappear:

  1. go to options->libreoffice->appearance and change something.
  2. bring up the 'styles and formatting' window and click the 'character styles' tab.

Except the appearance submenu and the character styles tab don't seem to exist anymore, and I can't find anything equivalent.

What is a current, up-to-date way of changing the automatic formatting of hyperlinks?

EDIT: here are some images showing the problem--as per settings, the black link should appear blue?

hyperlink fail

colorsettings

1 Answer 1

7

The solution depends on how the hyperlinks are created. There are two ways to generate a hyperlink in Calc:

  1. Menu Insert -> Hyperlink
  2. using the HYPERLINK() function.

In the first case, LO Calc inserts a field.

In the second case, the result is "plain text" with additional functionality if the user clicks on the hyperlink text.

Formatting a "text hyperlink"

Formatting a "text hyperlink" (created using the HYPERLINK() function) works the same way as formatting any other text content: using direct formatting - applying text style properties directly using the toolbar or Menu Format -> Text; or using cell styles.

enter image description here

Formatting a "field hyperlink"

Formatting a "field hyperlink" (created using Menu Insert -> Hyperlink) is somewhat more complicated, but it has the advantage that LO will apply a certain styling by default:

The actual design of "field hyperlinks" in Calc is the result of two settings: Field shading, and link color. You can't set the link color on a per-document basis, instead changes are applied application-wide (will affect hyperlinks in writer, too).

LibreOffice <= 5.0.x.x:

To modify the "field hyperlink" link color (and in calc, the link background -> field shading):

Menu Tools -> Options -> LibreOffice -> Appearance. Search for "unvisited links" or "visited links", and change the color:

enter image description here

For the field background in Calc, scroll down to the Text Document section (!), and change the "field shadings" setting.

LibreOffice >= 5.1.x.x:

To modify the link color (and in calc, the link background -> field shading): Menu Tools -> Options -> LibreOffice -> Application Colors. Search for "Unvisited links" or "Visited links", and change the color:

enter image description here

For the field background in Calc, scroll down to the Text Document section (!), and change the "Field Shadings" setting.

Important:

Take care to tick the checkboxes at the left of the setting name (in the second screenshot: marked with red rectangle).

Important, too:

Don't apply magenta to hyperlinks, as in the second screenshoot - looks extremely ugly...

(LO 5.1.x: Tested with both Linux x86_64 and Windows 10)

8
  • As I said in the OP, the "appearance" submenu doesn't exist in the libreoffice version I'm using. It seems to have been moved to 'application colours'. s31.postimg.org/4vbdd4rp7/appcolors.png These settings don't seem to be taking effect--hyperlinks look like black text.
    – Rob F
    Apr 22, 2016 at 10:57
  • I made a new empty spreadsheet, added in a hyperlink and captured the problem in action, added the images to the OP.
    – Rob F
    Apr 25, 2016 at 22:27
  • I was hoping there was a way of having the formatting occur automatically for all hyperlink text. I'm also wondering what the practical reason is for having two ways of inserting links (seems the field way just has less flexibility).
    – Rob F
    Apr 26, 2016 at 12:07
  • @RobF: The "field" hyperlinks should work in every LO component (you can have hyperlinks in writer, impress and so on, too). The HYPERLINK() function may be added for compatibility reasons to other Spreadsheet software. Also, it allows for dynamic hyperlinks (based on other spreadsheet values). If you want LO to format your hyperlinks in a coherent way, you should use the "field" hyperlinks, esp. if the link target is static.
    – tohuwawohu
    Apr 26, 2016 at 12:52
  • It's dynamic, hence the problem.
    – Rob F
    Apr 27, 2016 at 20:35

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .