6

I love the default fancy output of ccze, but I can't seem to get it scroll property. Executing

tail -f something.log | ccze

from an X terminal works, but I can't scroll back once the screen has been filled (shift+pgup doesn't do anything).

How can I get it to work as expected?

  • as far as I can see, that is not possible with ccze. With multitail it is, although its colouring capabilities are not comparable to ccze/colorize. – natxo asenjo Apr 21 '16 at 11:38
  • it makes me think then how people actually use this think.. or what for.. :( – Kristof Jozsa Apr 21 '16 at 12:00
5

ccze uses the curses output mode by default. (n)curses is a screen drawing library typically used by fullscreen applications. It switches to the terminal emulator's so-called "alternate screen" which does not have a scrollbar buffer, and the contents of the other, "normal screen" is restored upon exit.

Instead of this, you should use its ansi output format which is enabled by any of the -A, --raw-ansi, -m ansi or --mode=ansi command line options.

0

I use ccze with less to scroll into logs:

ccze -A /var/log/logstash/logstash-plain.log | less -R

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.