10

I am experiencing an issue on Centos7 when attempting to start the network service. I receive the below error message.

Failed to start LSB: Bring up/down networking

The issue arised when I realised it wasn't taking my static IP address from the /etc/sysconfig/network-scripts/ifcfg-eth0 file (found below).

DEVICE=eth0
BOOTPROTO=static
IPADDR=192.168.0.16
NETMASK=255.255.255.0
HWADDR=B8:27:EB:C3:1E:EC
NM_CONTROLLED=no
ONBOOT=yes
TYPE=Ethernet

On reboot, the device would load with IP address of 192.168.0.7, clearly not that static IP address assigned, and not sure how it is getting information of a DHCP server (which I do have, my router)

I attempted to disable the NetworkManager, as this might have been causing havoc with the network service by issuing the below command.

systemctl stop NetworkManager

and then enable network

systemctl start network

again the same error came up, I then killed the dhclient process, and attempted to start network service once more and again got the same error.

Losing patience, since I did have connectivity to the internet at the time on the server through the DHCP IP, performed a "yum remove Network Manager" and tried a reboot, again to no avail. I'm not sure if that was a good idea or not, but hey it wasn't working anyway.

I seem to have exhausted suggestions I could find on the internet. Wondering if anybody else has any idea what might be going on.

edit: one more note, this is not a VM or related to Virtualisation in any way. This is simply a RaspberryPI 3

Many thanks.

Edit: Log entries:

Jan 01 00:00:06 <hostname> systemd[1]: Starting LSB: Bring up/down networking... 
Jan 01 00:00:06 <hostname> systemd[1]: network.service: control process exited, code=exited status=6 
Jan 01 00:00:06 <hostname> systemd[1]: Failed to start LSB: Bring up/down networking 
Jan 01 00:00:06 <hostname> systemd[1]: Unit network.service entered failed state 
Jan 01 00:00:06 <hostname> systemd[1]: network.service failed
  • Just to make sure it is just a typo... when you say /var/sysconfig/network-scripts/ifcfg-eth0 you actually do mean /etc/sysconfig/network-scripts/ifcfg-eth0, right? – zagrimsan Apr 21 '16 at 16:32
  • apologies, yes, my mistake, /etc/sysconfig/network-scripts/ifcfg-eth0 – dlyxzen Apr 21 '16 at 16:34
  • Have you made sure the HWADDR in that file really corresponds with the NIC? – zagrimsan Apr 21 '16 at 16:37
  • I have checked the output of "ifconfig -a" and yes the ethernet address output from here matches that I have placed in the file. – dlyxzen Apr 21 '16 at 16:58
  • Please post the system log from the boot time when the network interfaces are brought up, either from whichever file in /var/log/ those things get logged to in CentOS or from the output of journalctl -l -b 0. – zagrimsan Apr 22 '16 at 3:18
5

Just in case anyone is still having an issue with Centos 7 on the Raspberry Pi in regard to this 'LSB' error.

I eventually found out that the /etc/rc.d/init.d/network script that is run, will error out right away with status=6 if a specific file does not exist, namely /etc/sysconfig/network.
I have no idea why this file is required, as on another system I work on the file exists but is empty. But it didn't exist out of the box with the Centos 7 OS I got for my Raspberry. After going through all other steps (remove Network Manager, set static IP in ifcfg file, kill dhc process for Network Manager, etc) if you still get this error just try:

touch /etc/sysconfig/network

The file can be empty. Just has to exist.

Then restart network service:

systemctl restart network

And voila. I realize this is a very small fix, but I went through all the headaches and tries above before finding this and I was good to go after.

4

I recently have had the same issue i.e. network.service failure

Failed to start LSB: Bring up/down networking

The solution worked for me was disabling the NetworkManger:

systemctl stop NetworkManager
systemctl disable NetworkManager

Rebooted and network.service was active (running).

2

You should use

BOOTPROTO=none

instead of

BOOTPROTO=static

The former is the correct syntax in RHEL / CentOS 7.

  • Could you please explain how this is might help solve the problem here, if you are posing it as an answer ? Otherwise, you can add it as a comment, saying it is something to try. – MelBurslan Apr 23 '16 at 18:28
  • Hint: the basis for this recommendation can be found in CentOS docs... – zagrimsan May 1 '16 at 5:26
  • 1
    You're referencing CentOS 5 documentation?! That's completely irrelevant to CentOS 7, – pgoetz Jan 28 '17 at 0:52
  • 2
    This answer is correct. Just because there is no glimmer you should not downvote correct answers. In RedHat 7 there is no BOOTPROTO=STATIC. Reference: unix.stackexchange.com/questions/167083/… – ora-600 Mar 28 '17 at 13:51
0

I got the same error trying to start i2p as service. I noticed however that parts of the Linux Standard Base support package were not installed on my system. After installing those there was no problem anymore.

-1

Delete the BOOTTOPRO="" and IPADDR="" lines. I came to this thread with the same problem. Initially, I had added the BOOTTOPRO and IPPADDR lines to set static values for enp0s3. After deleting these two lines, I was able to do systemctl restart network.service

  • 1
    If you remove IPADDR=...then you cannot configure a static IP. This is not really helpful. – ora-600 Mar 28 '17 at 13:55

protected by Community Jul 27 '17 at 14:59

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.