1

I need access a remote windows machine which I don't have any privilege on. The machine runs windows server 12R2, and the sys admin tells me that the RDP protocol there is the latest one. I tried to connect to the machine with xfreerdp and I get:

xfreerdp -u <username> <ip.address.of.machine>
connected to <ip.address.of.machine>
Password:
SSL_read: Failure in SSL library (protocol error?)
Authentication failure, check credentials.
If credentials are valid, the NTLMSSP implementation may be to blame.

The username and password are valid. I do have to mention that I was asked to write the username as <uni-users>\<myusername>. I read in several places that I need to disable nla security feature, which I don't think the sys admin will do. Is there a proper way to overcome this?


Edit

I can connect to the remote machine from a windows machine, here is the rdp definition fine

screen mode id:i:2
use multimon:i:0
desktopwidth:i:1920
desktopheight:i:1080
session bpp:i:32
winposstr:s:0,1,400,195,1200,795
compression:i:1
keyboardhook:i:2
audiocapturemode:i:0
videoplaybackmode:i:1
connection type:i:7
networkautodetect:i:1
bandwidthautodetect:i:1
displayconnectionbar:i:1
enableworkspacereconnect:i:0
disable wallpaper:i:0
allow font smoothing:i:0
allow desktop composition:i:0
disable full window drag:i:1
disable menu anims:i:1
disable themes:i:0
disable cursor setting:i:0
bitmapcachepersistenable:i:1
full address:s:<ip.address.of.machine>
audiomode:i:0
redirectprinters:i:1
redirectcomports:i:0
redirectsmartcards:i:1
redirectclipboard:i:1
redirectposdevices:i:0
autoreconnection enabled:i:1
authentication level:i:2
prompt for credentials:i:0
negotiate security layer:i:1
remoteapplicationmode:i:0
alternate shell:s:
shell working directory:s:
gatewayhostname:s:
gatewayusagemethod:i:4
gatewaycredentialssource:i:4
gatewayprofileusagemethod:i:0
promptcredentialonce:i:0
gatewaybrokeringtype:i:0
use redirection server name:i:0
rdgiskdcproxy:i:0
kdcproxyname:s:
drivestoredirect:s:
1

Maybe they publish RDP using a remote desktop gateway?

In this case you'll need to provide "/g:gateway" switch.

  • I can log easily from windows machine to the server, so I don't think that's the case. How do I use the tag or check if I need it or not? – Yotam Apr 21 '16 at 9:23
  • If you already connect from windows client you should have something in advanced settings of saved RDP file. – realpclaudio Apr 21 '16 at 9:52
  • I've edited my question, adding the rdp file content. – Yotam Apr 21 '16 at 10:44
  • no, unless you edited lines from gatewayhostname you're definetely not using a remote desktop gateway. btw here's the way i use freerdp: xfreerdp /v:RDP hostname /u:username /d:domain /p:password. if you have strange characters in password remember to escape them \ – realpclaudio Apr 21 '16 at 10:51
  • Which OS, my machine doesn't accept this notation, only the regular - one – Yotam Apr 21 '16 at 11:02
1

try rdesktop works just fine and is simple to use. When you want a GUI try remmina

  • 1
    The reason that I switched to xfreerdp was because this program would actually give information. rdesktop yields Error: recv: Connection reset by peer while remmina gives Unable to connect to RDP server <ip.address.of.machine> – Yotam Apr 21 '16 at 12:55

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.