0

I'm trying to connect to the local university eduroam wifi where I work with my Debian Jessy (xfce) laptop.

The wifi is protected as WPA- EAP : TLS (using ssh key pairs .cer and .pem)

I tried using wicd, but I permanently get an error of 'bad password', I'm not sure how to troubleshoot the connect (I can't how to get the debug messages going through the terminal to work out what isn't connecting).

So I decided to try connecting directly via wicd (they supply the config and a script).

here is the output after I attempt to connect using wpa_supplicang

$:~/ sudo wpa_supplicant -Dnl80211 -iwlan0 -c/etc/wpa_supplicant.conf
Successfully initialized wpa_supplicant
wlan0: Trying to associate with c4:7d:4f:4b:3f:71 (SSID='eduroam' freq=2437 MHz)
wlan0: Associated with c4:7d:4f:4b:3f:71
wlan0: CTRL-EVENT-EAP-STARTED EAP authentication started
wlan0: CTRL-EVENT-EAP-PROPOSED-METHOD vendor=0 method=21
wlan0: CTRL-EVENT-EAP-METHOD EAP vendor 0 method 21 (TTLS) selected
wlan0: CTRL-EVENT-EAP-PEER-CERT depth=3 subject='/C=SE/O=AddTrust AB/OU=AddTrust External TTP Network/CN=AddTrust External CA Root'
wlan0: CTRL-EVENT-EAP-PEER-CERT depth=2 subject='/C=US/ST=UT/L=Salt Lake City/O=The USERTRUST Network/OU=http://www.usertrust.com/CN=UTN-USERFirst-Hardware'
wlan0: CTRL-EVENT-EAP-PEER-CERT depth=1 subject='/C=NL/O=TERENA/CN=TERENA SSL CA'
wlan0: CTRL-EVENT-EAP-PEER-CERT depth=0 subject='/OU=Domain Control Validated/CN=radius.u-bordeaux.fr'
wlan0: CTRL-EVENT-EAP-SUCCESS EAP authentication completed successfully
wlan0: WPA: Key negotiation completed with c4:7d:4f:4b:3f:71 [PTK=CCMP GTK=TKIP]
wlan0: CTRL-EVENT-CONNECTED - Connection to c4:7d:4f:4b:3f:71 completed [id=0 id_str=]
wlan0: WPA: Group rekeying completed with c4:7d:4f:4b:3f:71 [GTK=TKIP]
wlan0: WPA: Group rekeying completed with c4:7d:4f:4b:3f:71 [GTK=TKIP]
wlan0: WPA: Group rekeying completed with c4:7d:4f:4b:3f:71 [GTK=TKIP]

Here the command seems to authenticate, and then connect. However I am unable to ping any ip, and hence no internet, no email from laptop (and worse no connection to my git repo !).

Is anyone able to give my any clues as to what is wrong in my setup up, or how to troubleshoot. I'd really like to get this working.

All help is hugely appreciated.

David

  • Have you tried running a DHCP client after manually running wpa_supplicant, such as dhclient? What is the output of ip address and ip route? – johnLate Apr 21 '16 at 22:14
  • @johnLate i've tried dhcp -wlan0, but it seems to just hang, and no change is visible. I've been playing again with wicd. and noticed that it's defaults to using wext to connect (not nl80211 above). I'll try again in a while once I get to the office. – DaveM Apr 22 '16 at 6:36
1

This may sound ridiculous, but it works !

I think in the first instance with all the 'messing around' I had been doing trying to get the wifi to work I had ended up with multiple wpa_supplicants running, or an issue with a conflict in wicd.

Anyway, I closed / stoped everything...

sudo killall wpa_supplicant
sudo /etc/init.d/wicd stop

and then when I did

sudo wpa_supplicant -Dnl80211 -iwlan0 -c/etc/wpa_supplicant.conf -B

I got a different response, a simple Successfully initialized wpa_supplicant

Then running

sudo dhclient -d wlan0

returned success... for the first time. previously it just hung, which I assumed was an fault in wpa_supplicant (although I may be wrong)

Internet Systems Consortium DHCP Client 4.3.1
Copyright 2004-2014 Internet Systems Consortium.
All rights reserved.
For info, please visit https://www.isc.org/software/dhcp/

Listening on LPF/wlan0/ac:81:12:70:6f:22
Sending on   LPF/wlan0/ac:81:12:70:6f:22
Sending on   Socket/fallback
DHCPDISCOVER on wlan0 to 255.255.255.255 port 67 interval 6
DHCPREQUEST on wlan0 to 255.255.255.255 port 67
DHCPOFFER from 123.456.789.123
DHCPACK from 123.456.789.123
bound to 987.654.321.321 -- renewal in 1494 seconds.

So I'm now happily making this response from my now connected laptop. Cool

now all I need to do is to enable the same connection via wicd, and I'll be super happy.

David.

| improve this answer | |
  • This worked for me, I was constantly trying to ifup wlan0, but the necessary thing was to just use the wpa_supplicant command and then run dhclient (Although the command stops after "bount to..." and doesn't completely return) . Well done. – ederollora Oct 21 '16 at 8:16
0

I had the same issue of establishing a connection to eduroam but being unable to ping anything with my connection.

I had a chat with our IT support guys and having found one who knew something about linux we were able to solve the problem. He told me that a some common network cards have problems connecting to eduroam and that they often gave the problem of a connection without any data transfer although he hadn't seen it on a linux machine before.

My Intel Centrino card is one of those he knew had issues so we tried with a usb wifi dongle and confirmed that the connection sprang into life immediately.

The workaround is to disable 11n.

It may be slightly different for Debian but on Fedora I was able to fix the problem by creating a file "iwlwifi.conf" in /etc/modprobe.d/ containing the line "options iwlwifi 11n_disable=1" and then rebooting.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.