0

I just installed ubuntu server (the installer connected to the internet with no troubles), and I cannot get it to connect wirelessly to the internet. I've googled to no avail, as there is no ethX device listed when I run ifconfig. Here is the output of ifconfig:

lo        Link encap:Local Loopback
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:65536  Metric:1
          RX packets:1136 errors:0 dropped:0 overruns:0 frame:0
          TX packets:1136 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:84056 (84.0 KB)  TX bytes:84056 (84.0 KB)

I've tried running wget --spider https://example.com and using sudo apt-get install <app-name> and both have resulted in Name not resolved, even though the usb installer was able to connect to the internet perfectly fine.

EDIT: after running lspci, I can see the wireless network controller listed:

0c:00c0 Network controller: Intel Corporation Ultimate N WiFi Link 5300

I'm not sure if this is relevant, but I also saw the following listing under lsusb

Bus 005 Device 002: ID 0a5c:5800 Broadcom Corp. BCM5880 Secure Applications Processor

EDIT 2: My ethernet controller is also listed under lspci:

00:19.0 Ethernet controller: Intel Corporation 82567LM Gigabit Network Connection (rev 03)

EDIT 3: I'm running the 4.2.0-16-generic kernel.

  • wget or apt will not work with a loopback interface. Try lsusb - do you see your NIC now? (You have a usb to rj45 network adapter right?) – varmox Apr 21 '16 at 12:16
  • Please edit your question to include the output of lspci and/or lsusb, showing the WiFI device entry. (If you are completely sure you know which lines are relevant you may omit the other lines from your question.) – roaima Apr 21 '16 at 13:27
  • This should be supported by the e1000e driver / kernel module, which you can verify with a quick google. Check and see if you have that module loaded. Intel drivers are usually problem-free. See for example downloadcenter.intel.com/download/15817/… What kernel are you running? It looks like this card has been supported by this driver for a long time. – Faheem Mitha Apr 21 '16 at 16:18
  • After running make install in the src directory of the install, it doesn't appear in the tab completion of modprobe, even though I've followed the directions perfectly and gotten no errors or warnings. I get e100, and e1000, but not e1000e. And loading the e100 and e1000 modules didn't help. And ifconfig never changes. Rebooting still didn't allow me to load the kernel module. – Potassium Ion Apr 22 '16 at 15:21
  • Also, I'm trying to get the Ultimate N Wifi Link to work, not necessarily the ethernet controller. Does the wireless controller depend on the ethernet? because I don't necessarily need the drivers for it if it doesn't. – Potassium Ion Apr 22 '16 at 15:40
0

Try installing with upgrades from the installation itself. Some Driver files or the files required for compiling the driver might be missing.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.