2

I´m pretty new to Linux so I've been having a hard time fixing this. Running the latest version of Mint. The files are stored on an auto-mounted NTFS partition. I can access the share, I can authenticate with my owner account (the one I set a password for with smbpasswd) and I can browse all files and directories. However, as soon as I want to open a file it refuses.

I am using the following smb.conf: http://pastebin.com/MRbgRhiG

The Videos folder is a symlink to my mounted drive, which is auto mounted as follows:

/etc/fstab line;

UUID=7C5B812C61FD7D26 /media/storage/    ntfs-3g        auto,uid=1000,gid=1000,umask=0000 0 0

This mounts the directories for my owner account (vincent) and group. Same for files as proven with ls -l in a subdirectory under the shared folder (Anime/Neon Genesis Evangelion/).

-rwxrwxrwx 2 vincent vincent  736292972 Apr 18 00:12 Neon Genesis Evangelion 01 .mp4

Checking the properties of files and directories also shows full accessibility.

  • What does it show when it "refuses" to open? – Jeff Schaller Apr 20 '16 at 14:11
  • @JeffSchaller Depends on the client used to acces, Kodi gives nothing specific and a generic error message, file browsers simply times out. Would a log be helpfull? As far as I understand smb creates logs for every client. I´ve tried to connect through a simple file browser and Kodi. Would a kodi error log be usefull? – Gijsbouwse Apr 20 '16 at 14:19
  • We don't have much else to go on, so any details you can provide as to the errors would be helpful. – Jeff Schaller Apr 20 '16 at 14:22
  • I would suggest you start by looking at the samba logs /var/log/samba/log.%m. This will tell you if a) the connection is even being established and if so list any errors. – SeeJayEmm Apr 20 '16 at 14:26
  • @SeeJayEmm Thanks, hadn´t added those logs yet because I wasn´t sure which ones would be usefull. log.%m pastebin.com/1zYS29gM If it is of any use, this is the part of the log file Kodi created when I tried to acces a file. pastebin.com/LaE0PYgY – Gijsbouwse Apr 20 '16 at 14:29
0

This seems to be an issue with the 4.3.8 update on Ubuntu. There are tons of posts about it on various sites with no clear answer on a fix (as multiple people have tried various things and have had different results).

Some have found if you comment out 'security = share' (using #) in /etc/samba/smb.conf it solves the problem, however, some haven't found it to work.

Others have found adding 'client use spnego = no' to the conf has solved it, but once again others have not.

So far, I haven't found a fix that works for me and I'm on KODIbuntu 14.04.4 x86 with the 4.3.8 Samba updates.

  • Intresting. Thanks for the heads up. Things mentioned in your post didn´t work sadly. If it really is an Ubuntu problem I´ll be trying out a different distro. Shame, Mint seemed very beginner-friendly. – Gijsbouwse Apr 20 '16 at 16:41

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.