2

I am running the EDG-12.2.1-Trn (CentOS 6.6 64-bit) VM on Virtual Box. This is the Oracle Database VM.

When I try sharing a folder, through VirtualBox, it shares successfully (automatically), and there is a shortcut on the desktop too.

When I run the shortcut, it says there is a permissions error. I looked in the terminal, and saw that it looks like this:

[root@edqtrn media]# ls -l
ls: cannot access sf_my_share: Protocol error
total 14
drwxrwx---. 2 root   vboxsf   4096 Dec  2  2014 sf_av_share
drwxrwx---. 2 root   vboxsf   4096 Jan 23  2015 sf_data
drwxrwx---. 2 root   vboxsf   4096 Dec  2  2014 sf_share
d?????????? ? ?      ?           ?            ? sf_my_share
dr-xr-xr-x  6 oracle oinstall 2048 Mar  4 11:45 VBOXADDITIONS_5.0.16_105871
[root@edqtrn media]# 

Why are there ? in the directory listing?

sf_my_share is the folder I want to share and read the files in it. I have shared it properly in VirtualBox (i.e. Devices > Shared Folders > Shared Folders Settings > Added a folder in: Machine = share, Folders = C:\temp\my_share\, Auto-mount = Yes and Access = Full - Read Only is not set).

  • @RuiFRibeiro - well, I have managed to use WinSCP, so don't need to share a folder as such anymore, but is still odd why it is showing ?'s lol – Kevdog777 Apr 20 '16 at 10:26
  • 1
    My Netowrk adapter, in the Settings on VBox, was set to NAT. As soon as I changed it to Bridged, then restarted the VM, it worked and didn't show the ?'s. – Kevdog777 Apr 20 '16 at 10:30
1

Check the permissions of your sf_my_share directory.
If you have read but not execute permissions on this directory, then you have enough rights to list the files in that directory, but you can't actually use these files or get more detailed information about them.

  • Yeah, that's why I did a ls -l on the directory (even under root), and still had no permissions on the file - it was substituted with ?'s. – Kevdog777 Apr 20 '16 at 10:16
1

Check the filesystem that hosts your sf_my_share directory. Seem like ls can't stat this directory, may be because of the the filesystem's mount options

0

It definitely looks like it could have been a permissions or a network issue. But on my last note, I mentioned that:

My Netowrk adapter, in the Settings on VBox, was set to NAT. As soon as I changed it to Bridged, then restarted the VM, it worked and didn't show the ?'s

So this seemed to have fixed it.

I haven't seen this since, so it had to have been my network adapter.

0

If you have Make Permanent option in the shared folder option, it can cause this. I had this problem once in the past and then did an unmount and deselect Make permanent and left only Auto mount and never came across this error at all.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.