0

I just uninstalled Chrome via the software manager due to an annoying bug with the console in devtools - thinking that an uninstall and reinstall was worth a try to fix it.

Trying to install it again now, i get this:

$ sudo apt-get install google-chrome-stable

Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies.
 google-chrome-stable : Depends: libstdc++6 (>= 4.8.0) but 4.6.3-1ubuntu5 is to be installed
                        Depends: lsb-base (>= 4.1) but 4.0-0ubuntu20.3 is to be installed
E: Unable to correct problems, you have held broken packages.

This message is confusing - i don't know why i would have requested an "impossible situation" and i'm not using the unstable distribution. Also " you have held broken packages." - i have held them but i don't at the moment? What is this actually saying?

Here's my OS info:

$ cat /etc/linuxmint/info
RELEASE=13
CODENAME=maya
EDITION="MATE 64-bit"
DESCRIPTION="Linux Mint 13 Maya"
DESKTOP=MATE
TOOLKIT=GTK
NEW_FEATURES_URL=http://www.linuxmint.com/rel_maya_whatsnew.php
RELEASE_NOTES_URL=http://www.linuxmint.com/rel_maya.php
USER_GUIDE_URL=http://www.linuxmint.com/documentation.php
GRUB_TITLE=Linux Mint 13 MATE 64-bit

Grateful for any advice.... Max

1

You need to remove google chrome

sudo apt-get remove google-chrome-stable
sudo rm /etc/apt/sources.list.d/google-chrome.list*
sudo apt-get -f install

Add the key

wget -q -O - https://dl-ssl.google.com/linux/linux_signing_key.pub | sudo apt-key add -

change the sources.list entry for Google Chrome

sudo sh -c 'echo "deb [arch=amd64] http://dl.google.com/linux/chrome/deb/ stable main" > /etc/apt/sources.list.d/google-chrome.list'
sudo apt-get update

install google Chrome

sudo apt-get install google-chrome-stable

Edit Google has end support for Linux-mint maya (based on Ubuntu 12.04) More info

As part of Chrome Platform Deprecation CPS (2015-10), we will end support for Google Chrome on 32-bit Linux, Ubuntu Precise (12.04), and Debian 7 (wheezy) in early March, 2016.

  • Thanks - i just ran through all that and still get the same error message. – Max Williams Apr 20 '16 at 10:35
  • 1
    Just saw your edit. Well that sucks. Guess i need to upgrade my OS. – Max Williams Apr 20 '16 at 11:27
  • It's a good idea to upgrade to the latest stable version. – GAD3R Apr 20 '16 at 11:34

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.