I am wanting to get the Ibus IME (Anthy engine for Japanese input) working in all my window managers.

Unity is fine, along with Compiz and Metacity.

But the one I really want to get it working with is spectrwm (a tiling window manager - i3m, xmonad are others).

I tried running the ibus-daemon, but any of they keyboard shortcuts to change to the different input method don't work. I can't tell whether this is because Ibus isn't working, or it requires the Gnome-panel to function, or just the keyboard shortcuts are being stolen by the desktop manager and thus not passed to ibus.

Where do I start in debugging this?

2 Answers 2


While in the middle of posting this question, I found the answer haha.

I first entered the following into a terminal:

$ ibus engine

I then got the list of engines to find what I needed to change it to (output cropped for brevity):

$ ibus list-engine
language: Estonian
  xkb:ee::est - Estonian
language: Slovak
  xkb:sk:qwerty:slo - Slovak (qwerty)
  xkb:sk::slo - Slovak
language: Romanian
  xkb:ro::rum - Romanian
language: Japanese
  xkb:jp::jpn - Japanese
language: Japanese
  anthy - Anthy

I then selected the Anthy engine (which also has support for English input so I don't need to keep swapping engines):

$ ibus engine anthy

Although there was no output for that command, using the keyboard shortcuts built in (Ctrl + ,) to go to the next input method (e.g. hiragana, katakana, english etc).

EDIT: I also found the way to swap between the engines (US to anthy) using a keyboard shortcut. First, open the ibus settings:

$ ibus-setup

Selecting the Input Method tab, ensure the 'Customise active input methods' checkbox is ticked. Then, using the scrolldown (shown with the text 'Select an input method' to find the Japanese Anthy input method. Then click the 'Add' button on the right hand side of the screen. This will add 'Japanese - Anthy' to the list of Input Methods in Ibus. Now, when you press Ctrl + Space, it will properly switch between the English input method engine and the Japanese Anthy input method engine. The commands to do so via the terminal still work, this just enables it to be done via a keyboard shortcut.


For me the ibus is not running, it states "Can't connect to ibus" when I did ibus restart. My solution was: Add this to .bashrc:

export GTK_IM_MODULE=ibus
export XMODIFIERS=@im=ibus
export QT_IM_MODULE=ibus
ibus restart

The ibus restart has to be there because even added the required environment variables, ibus still need to restart to function properly. After all, log out and log back in.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .