0

My touchpad does not work in Linux Mint, which I recently installed. I can connect a mouse and it works fine. I have an Asus Zenbook Pro UX501 laptop.

I tried a bunch of things, but none of them worked. I checked in hardware >> mouse and touchpad, and the touchpad was turned on according to the settings. I tried pressing the F9 key on my keyboard which looks like a mouse with a line through it, but the exact same shape with the line appears on the screen which, means it is turned off, I assume. I also installed touchpad-indicator, but it won't run for some reason on my Linux.

Also, when I run dmesg | grep mouse, this is what I get:

[ 0.918702] mousedev: PS/2 mouse device common for all mice

I ran:

 cat /proc/bus/input/devices

and I got a block with the touchpad in it:

I: Bus=0003 Vendor=0457 Product=10cc Version=0111
   N: Name="USBest Technology SiS HID Touch Controller"
   P: Phys=usb-0000:00:14.0-12/input0
   S: Sysfs=/devices/pci0000:00/0000:00:14.0/usb1/1-12/1-12:1.0/0003:0457:10CC.0002/input/input5
   U: Uniq=
   H: Handlers=mouse1 event5 
   B: PROP=2
   B: EV=b
   B: KEY=400 0 0 0 0 0
   B: ABS=260800000000003
13
  • Model would be helpful...
    – Android Dev
    Apr 19 '16 at 18:30
  • Zenbook Pro UX501
    – Navid Nazari
    Apr 19 '16 at 18:33
  • I did. 3 things that I mentioned in the second paragraph are all that I found in the forums, and none of them worked for me. Apr 19 '16 at 18:58
  • I did, and I got this: Apr 19 '16 at 19:18
  • [ 0.918702] mousedev: PS/2 mouse device common for all mice Apr 19 '16 at 19:19
-1

I understand in linux they might be missing some driver files one way to chk is to reinstall you linux.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.