4

This issue started after latest updates installation, probably in last 2-3 days. When I try to open Terminator I get error,

Traceback (most recent call last):
  File "/usr/bin/terminator", line 23, in <module>
    import psutil
  File "/usr/lib64/python2.7/site-packages/psutil/__init__.py", line 181, in <module>
    raise ImportError(msg)
ImportError: version conflict: '/usr/lib64/python2.7/site-packages/psutil/_psutil_linux.so' C extension module was built for another version of psutil (different than 2.2.1)

I am using Centos 7.2 (64 bit). I did not installed any other software or any other python libraries in last one month.

4

I ran into the same problem and worked around it by installing the version of psutil listed in the error.

sudo pip install psutil==2.2.1

0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.