1

I am trying to install Kali Linux 64-bit rolled version in UEFI mode so created a bootable USB using Universal USB Install, created /EFI/BOOT and copied .efi files to it.

I turned off secure boot. I disabled fast boot both: in Windows 10, as well as in BIOS.

Finally successfully opened Kali but when I selected the "live" mode I got the following error:

enter image description here

And it is not continuing further. My system has 128 GB SSD and 1 TB normal HDD because it is rog series. How can I boot into Kali Linux?

  • I'm facing the same issue... Did you find a resolution ? – Punit Arya Apr 19 '16 at 17:21
  • i am having the same issue (kali 2016.2) with same laptop. even with fedora too – Krishna Torque Sep 23 '16 at 7:10
1

I had the same issue as all of you and found the solution on the Fedora wiki (while trying to get the EFI files) The problem is the programs most of us use to create our live USBs (Rufus, UUI, etc.) only work in Legacy mode. I used the Fedora Media Writer and was able to boot in UEFI with no trouble. My computer recognized Kali as soon as it was plugged in. It's a very straight forward install. It creates a locked partition with the Kali ISO files and then a second partition with what looks like a mini grub loader to boot from. Looking at the Kali website I believe the guide there does something similar because persistence ends up being sda3 not 2 like it would with Rufus.

TLDR: Use Fedora Media Writer to create your live USB. The other programs only work in Legacy mode

0

I'm having the exact same issue on that Laptop. What you can do is install Kali 2.0. Enable Legacy boot in BIOS (whatever it's called) and then change boot order to P2 (or whatever the DVD drive is) but not UEFI.

That will work but there seems to be an issue in the latest 2016 that prevents the installation, I believe it might be a graphics driver issue.

0

I've got the same issue with same laptop, it seems to be a recurent problem with new OSes (tried with Mint 18 too) However, I was able to run and install it on my drive, but when I try to launch it afterward, it can't (either it's stuck while loading, or there is a freeze after login), I suspect graphics problems. I ultimately managed to run it by changing the GRUB parameters (while in the blue launching screen, press "e" to access parameters), then add " acpi=off" at the end of the linux line (almost at the end), don't worry to change something wrong, it goes back to the initial parameters. This parameters allows it to run without launching ACPI support, so you'll have less hardware support, but this will boot.

After, it depends on people it would seem : some just install nvidia drivers and it works, others have more problems... I personnaly downgraded by installing 2.0, which works fine until now

0

I too was having difficulty! I have the same ROG laptop but what I did was just simply disabled the secure boot option in the bootloader. Then I created the Win32 Disk imager as listed on Kali's website (" http://docs.kali.org/downloading/kali-linux-live-usb-install ") just follow the method the Linux method works too.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.