1

I'm trying to install RVM in a CentOS server which for some weird reason I do not have access to internet.

One of its dependencies is the library libyaml-devel.

I already installed the libyaml downloaded from here: http://pyyaml.org/download/libyaml/. But it didn't solve the problem.

First:

Where do I find the official repository of libyaml-devel (Yes, I tried Google. I couldn't find it here: http://pyyaml.org/wiki)

Second:

Probably I will have other issues with other libs on this server. How to install other libs easily without internet access (and of course, without yum install)?

Edit:

  • I'm using CentOS 6.5

Edit 2:

Using another machine, I downloaded libyaml-devel from 2 sources, moved to the server and tried install it, without success.

http://pkgs.repoforge.org/libyaml/libyaml-devel-0.1.4-1.el6.rf.x86_64.rpm

$ sudo rpm -Uvh libyaml-devel-0.1.4-1.el6.rf.x86_64.rpm
warning: libyaml-devel-0.1.4-1.el6.rf.x86_64.rpm: Header V3 DSA/SHA1 Signature, key ID 6b8d79e6: NOKEY
error: Failed dependencies:
    libyaml = 0.1.4-1.el6.rf is needed by libyaml-devel-0.1.4-1.el6.rf.x86_64
    libyaml-0.so.2()(64bit) is needed by libyaml-devel-0.1.4-1.el6.rf.x86_64

ftp://195.220.108.108/linux/centos/6.7/os/x86_64/Packages/libyaml-devel-0.1.3-4.el6_6.x86_64.rpm

$ sudo rpm -Uvh libyaml-devel-0.1.3-4.el6_6.x86_64.rpm
error: Failed dependencies:
    libyaml = 0.1.3-4.el6_6 is needed by libyaml-devel-0.1.3-4.el6_6.x86_64
  • Does CentOS have binary packages for libyaml? What version of CentOS are you running? You can still do binary packages installs without the net. But I suggest fixing your net connection asap. – Faheem Mitha Apr 15 '16 at 15:29
  • Actually I have connection, but I'm working for a company which have stupid security rules and don't give access to most of useful domains/sites. – Rodrigo Apr 15 '16 at 15:35
  • 1
    That sounds annoying. I suggest you either get hold of a binary RPM that will work on CentOS 6.5, or rebuild a suitable source rpm on your machine. And yes, libyaml-devel has libyaml as a dependency. You first need to install libyaml. Does your machine know about yaml? Try yum search yaml and see what you get. – Faheem Mitha Apr 15 '16 at 16:02
  • I've installed yaml from source using this guide: collectiveidea.com/blog/archives/2011/10/31/… – Rodrigo Apr 15 '16 at 16:04
  • You should really install everything using binary packages. Having binary packages that depend on installed-from-source software is possible, but not a good idea in general. – Faheem Mitha Apr 15 '16 at 16:06
1

Why don't you install the same CentOS 6.5 where you can download updates via yum, and go this way:

http://www.cyberciti.biz/faq/yum-downloadonly-plugin/

You can download all rpm's you need and then install them on your server.

2

The official source for libyaml is on bitbucket. That doesn't however give you libyaml-devel, as that is the CentOS specific packaging of those sources.

So the best thing to do is download the RPM on some other machine, transfer it and install. That will satisfy the requirement that libyaml-devel is installed and any depending packages will no longer complain about it not being installed. Once you have the libyaml-devel.rpm install it with the rpm command, it should not have any dependencies of its own.

The alternative, regenerating libyaml-devel yourself from the sources and the CentOS specific patches is much more difficult, unless you can get hold of the complete SRPM

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.