1

SOAP UI

What happens with fonts in my JAVA apps? SOAP UI screen as example (see toolbox)... I have no idea where is the problem.

SYS: up-to-date ARCH LINUX.

$ archlinux-java status
Available Java environments:
java-7-openjdk
java-8-jdk (default)
java-8-jre/jre
java-8-openjdk
9
  • Did you recently install new packages? I've had a similar problem when I installed font-config on RHEL because it changes the default OS font (which you can also change). Is the font of your terminals changed as well?
    – Centimane
    Commented Apr 14, 2016 at 10:49
  • Simply change the display font of Java should work. stackoverflow.com/questions/23284296/…
    – daisy
    Commented Apr 14, 2016 at 11:01
  • Simply change the display font of Java should work. stackoverflow.com/questions/23284296/…
    – daisy
    Commented Apr 14, 2016 at 11:02
  • @warl0ck That isn't work. :( Commented Apr 14, 2016 at 12:01
  • @Dave Font-config installed. If i drop Font-config it's help? In term i set ubuntu mono manually. Commented Apr 14, 2016 at 12:02

1 Answer 1

1

I found solution! first:

$ sudo nano /etc/environment

Second (add this string to config):

_JAVA_OPTIONS='-Dawt.useSystemAAFontSettings=setting'

But I did't understand something. According to this article setting is not a value. Also above described parameter earlier is not specified at all and this problem been present.

2
  • According to the article you cite, settings is one of off, on, gasp, lcd, lcd_hbgr and a few redundances of the above.
    – steffen
    Commented Mar 21, 2017 at 21:14
  • You're supposed to replace setting with one of the listed values; that's why setting is in italics in the article you linked. I'm guessing that Java sees setting as an invalid value and uses a default one instead, and that default one is what you need to set it to. There aren't too many options so I'd recommend just trying them all
    – pxeger
    Commented May 28, 2021 at 14:15

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .