2

I was using terminator for my terminal emulator, but I'm seeing huge performance issues with it. ie, launching a new terminal session takes 20-30 seconds on my netbook. gnome-terminal is better, but still takes 10-15 seconds to launch.

xterm however takes only a second or two. I'm fine using it, but I absolutely loathe the way it handles copy/paste.

How do I configure xterm to not copy something when highlighted via mouse (since I use a clipboard manager and I don't want my recently used entries to get nuked every time I select something) and use shift+ctrl+c/shift+ctrl+v for copy/paste?

OS is Debian 8, window manager is fluxbox.

Thanks!

  • xterm decides what to do based on the translations resource, which by default allows a choice between copying to the primary selection or to the clipboard. What should it do when you highlight something, if not copying a selection? – Thomas Dickey Apr 13 '16 at 23:38
  • When you are starting next terminator you can hit ctrl+shift+i which will spawn new window within the same process. That should take at most one second, even on old netbooks. You may also consider to start new tab (instead of new window) with ctrl+shift+t. Splitting terminal is yet another option. – jimmij Apr 14 '16 at 0:37
  • Would you accept an answer that involves switching to another fast terminal emulator, like st? – Alexander Mar 12 at 18:22
3
+100

I was able to use CTRLSHIFTC and CTRLSHIFTV for Copy-and-Paste with XTerm by adding

XTerm*vt100.translations: #override \
    Shift Ctrl <Key> C: copy-selection(CLIPBOARD) \n\
    Shift Ctrl <Key> V: insert-selection(CLIPBOARD)

to my ~/.Xresources and reloading it with xrdb -merge ~/.Xresources.

Documentation of this feature can be found in xterm(1), “Custom Key Bindings”.

  • The xterm manual page shows a more complete version of this one. – Thomas Dickey Mar 12 at 21:06
  • @ThomasDickey Thank you (but really, mostly thank you for xterm), I added your link to the documentation to the answer. I hope finefoot doesn't mind. – derobert Mar 12 at 21:30
0

It does not copy on selection. Well not really, in the same way that nothing is copied with ctrl-c, or right click copy. This is a terrible metaphor, that is used on Microsoft's windows: You right click a file on a USB storage, select copy, eject device, put it in a giffy bag, and hand it the DHL. Then click paste, only to realise that it has not made a copy. The traditional X11 way is to paste previous selection, there is no copy. I miss this working properly, many modern applications use the broken MS ctrl-c, ctrl-v model.

To solve your problem, configure the clipboard manager to ignore selection.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.