7

I am not able to login into GNOME desktop, it happened yesterday after upgrade. In login screen, if I enter my password and press ENTER I am getting login screen again.

System details:

  • linux 4.4.5-1
  • gnome-shell 3.20.0-3
  • gnome-desktop 1:3.20.1-1
  • gnome-session 3.20.1-1
  • gdm 3.20.0-1

Logs:

Few tips for you to help me:

  1. I am able to login in GNOME Wayland session but not with default GNOME (with xorg)
  2. I created new user (from console) but same problem occurs when this new user tries to login.
  3. output of uname -a: Linux ArchLinux 4.4.5-1-ARCH #1 SMP PREEMPT Thu Mar 10 07:38:19 CET 2016 x86_64 GNU/Linux

Please ask if you need more info.

10 Answers 10

3

I had similar issue.. could solve it by restarting gdm:

login with Ctrl+Alt+F3 and type

systemctl restart gdm
1
  • This works thanks. But I have to do this every time.
    – Qian Chen
    Jan 15 '19 at 23:49
2

I guess the reason is

/etc/profile.d/bundler-exec.sh: line 12: `bundler-installed': not a valid identifier

in journalctl.log

Can you provide this file?

3
  • here is the script bundler-exec.sh ( sprunge.us/BKii ). can you please show what is wrong with it? Apr 13 '16 at 12:20
  • I don't familiar with ruby enough, so You can try to comment out all rows in this file to check the error will disappear.
    – Sild
    Apr 13 '16 at 12:44
  • moving that file to some other location solves my problem ;-). thanks Apr 13 '16 at 12:57
1

I had this problem too. It was solved when I deleted my ~/.ICEAuthority file and allowed it to be recreated.

1

I had the same problem after I copied config files over from another machine. So, in my case, my user didn't have permission on .Xauthority in my home folder.

To fix the permissions:

  • Press ctrl + alt + 3 at the login screen
  • Sign in with your user
  • Change the ownership of XAuthority to your user: sudo chown <user>:<user> .Xauthority
1

The actual problem was:

cat /var/log/messages | grep MIT-MAGIC-COOKIE-1

for example:

Nov 18 19:15:02 centos /usr/libexec/gdm-x-session[2596]: Invalid MIT-MAGIC-COOKIE-1 key$DISPLAY is not set or cannot connect to the X server.

Because I've had export DISPLAY=:0 set in ~/.bashrc, which user root did not have set.

1
  • thank you Martin!! my problem was also setting DISPLAY at startup config
    – salah
    Feb 11 at 4:01
1

so i was having this issue, i have gnome 3.30, im on MX Linux, and gdm3 wasn't letting log into any gnome desktop, until i tried the following thing: as soon as gdm3 is displaying, just wait for 10 seconds without hitting any key, and only then proceed to login. i don't know why but this worked for me

0

I had this problem and it turned out to be one of my Gnome Shell extensions, but I'm still not sure which one.

To check if this is your problem, open the Gnome Shell Extensions application (it will run in Cinnamon on Fedora and I'd bet other desktop environments). There is a "master" on/off switch that you can switch to Off and it will keep your existing on/off selections for the extensions. Then you can log in and see if you get kicked back.

My next step was to turn on the master switch and then turn off any extension that I didn't REALLY want, or that I'd recently enabled. I must've turned off the right one, because my logins are working fine now.

A few things that might indicate whether this is the cause of the problem for you: 1) Gnome 3 on Wayland and Xorg both kick you back to the login screen 2) Logging in with the Cinnamon or another desktop works fine.

I was never able to find a log that clearly indicated the problem, so if someone knows, that would be a nice addition to this thread.

0

I had the same problem. With:

  • GNOME Shell 3.38.1
  • Linux 5.9.2-arch1-1
  • GDM GDM 3.38.1

I deleted the cache with rm -r /home/username/.cache/*

This solution works for me.

1
  • clearing cache is not always recommended because some temporary but important data (which may or may not be retrievable) will be deleted. Dec 1 '20 at 9:53
0

This particular problem happened to me on RHEL8, after I installed TigerVNC. Probably some kind of conflict between VNC login and local graphical login, I don't know. So think about what programs you installed (and what services you added) before you last logged out - it's possibly that.

For a stopgap solution before I figure out why my VNC server is causing this, I simply stopped and disabled vncserver using systemctl. Then I was able to log in again.

Steps, briefly:

  1. Press ctrl + alt + F3 in login screen to switch to terminal
  2. Login per usual in terminal
  3. Run [sudo] systemctl list-unit *.service and find the one(s) associated with VNC server
  4. Run [sudo] systemctl disable <INSERT_SERVICE_NAME> --now to stop and disable the offending VNC server (or whatever you suspect is causing your problem)
  5. Run [sudo] systemctl restart gdm to restart GDM and launch GUI
  6. Login in GUI
0

I got into this Gnome login problem, after trying to enable non-supported Gnome extension in RHEL 8 (used it on RHEL 7 previously).

Going into Run level 3 (Ctrl + Alt + F3), renaming the extensions directory and restarting Gnome, would be the first remedy for this case:

cd ~/.local/share/gnome-shell/
mv extensions old_extensions && mkdir extensions
systemctl restart gdm

Hopefully it will allow you to login well. Now select and move back just the stable extensions, or use https://extensions.gnome.org/ to safely install them.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.