28

I use MATE on Fedora. At some point, the behavior of scrollbars on many applications has changed. When I click below a scrollbar, now the scrollbar jumps to where I clicked. Previously, it used to page down by one page (if I clicked anywhere below the current location of the scrollbar).

I preferred the old behavior. When on a very long page, the new behavior tends to make the scrollbar almost unusable: I can't control where I click precisely enough to control where the page jumps to.

Is there a way to regain the previous behavior? In other words, is there a way to make clicking on a scrollbar, below the current location of the scroll, to cause the window to go down by one page, rather than jumping to where I clicked?

This difference is most noticeable in Firefox, but is not limited solely to Firefox; it affects other applications, too.

2
  • This doesn't appear to be anything specific to MATE or Fedora. I recently started noticing the same annoying change in behavior, and I use fluxbox on Mint.
    – user39248
    May 5, 2016 at 2:13
  • Earlier: How To Change Scrollbar Action In GNOME 3.10. Dec 18, 2016 at 7:16

4 Answers 4

27

I had the same issue on Firefox 48, and this answer worked for me:

Create ~/.config/gtk-3.0/settings.ini and add

[Settings]
gtk-primary-button-warps-slider = false

I'm using XFCE, but Firefox is reading that setting for some reason. It also worked with other Gnome 3 applications, such as gnome-todo.

After creating that file, I only had to restart Firefox and its behavior was modified (no need to reboot).

4
  • Works for Firefox 50 too.
    – Max Yudin
    Feb 5, 2017 at 16:05
  • Thank you, they used to have a setting in about:config which they have taken away in later versions. you saved the day with this.
    – MitchellK
    Aug 15, 2017 at 13:30
  • Thanks, this actually impacts most apps in Linux Mint Cinnamon, such as Nemo file manager, Terminal, Firefox, etc! Apr 15, 2019 at 6:12
  • this works in xubuntu, firefox 50. Thanks!
    – Mariano L
    Jun 8, 2019 at 16:03
17

You get the old page-up/down behavior via right-clicking on the scroll bar.

5
  • 2
    Is there any way to swap these actions in a config file? Make the old behaviour the default left-click, and make jump-to-location work with right-click? Dec 29, 2017 at 22:43
  • Right-clicking simply seems to scroll very slowly. Useful for very precise scrolling. May 1, 2020 at 16:33
  • Middle click did the trick for me
    – Mastiff
    Jun 11, 2020 at 16:09
  • @Mastiff on which distribution/GnomeShell version? Middle-clicking on the Firefox scroll bar doesn't do anything using a Fedora 31 box of mine (GnomeShell in Wayland mode). Whereas right-clicking still works as described for me. Jun 11, 2020 at 16:37
  • Sorry for vagueness. In my case I was concerned with the gnome terminal. My version says 3.28.2
    – Mastiff
    Jun 11, 2020 at 17:42
5

I am not sure of the general case , but in FireFox, there is a configuration setting ui.scrollToClick=0 , which gives the behaviour you want.
If ui.scrollToClick=1 , then clicking the scrollbar will make it jump to that point.
Also, you can use shift-click for getting the opposite behaviour of the current FireFox setting.

1
  • 2
    Shift-click still working in 68.0, not ui.scrollToClick=0
    – Laurent G
    Aug 21, 2019 at 10:28
3

You get the page-up/down behavior via shift-clicking on the scroll bar.

H/T to Laurent G.'s comment on another answer.

1
  • 1
    Welcome to U&L, please take the tour and check the posting protocol, as well as how reference other posts by linking.
    – bu5hman
    May 1, 2020 at 17:45

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .