2

How do you run a standard Raspbian image in QEMU?

I'm following the instructions in this wiki, but the first step is failing.

I downloaded the kernal kernel-qemu-4.1.13-jessie and the Raspbian Jessie Lite image, but when I run:

qemu-system-arm -kernel kernel-qemu-4.1.13-jessie \
    -cpu arm1176 \
    -m 256 \
    -M versatilepb \
    -no-reboot \
    -serial stdio \
    -append "root=/dev/sda2 panic=1 rootfstype=ext4 rw init=/bin/bash" \
    -hda 2016-03-18-raspbian-jessie-lite.img

A QEMU window pops up and seems to show it booting correctly, but then it says "rebooting in 1 second" and closes. My local terminal only outputs:

pulseaudio: set_sink_input_volume() failed
pulseaudio: Reason: Invalid argument
pulseaudio: set_sink_input_mute() failed
pulseaudio: Reason: Invalid argument
Uncompressing Linux... done, booting the kernel.

Why is it rebooting even though I'm using the -no-reboot option? What am I doing wrong?

migrated from serverfault.com Apr 12 '16 at 10:25

This question came from our site for system and network administrators.

2

The problem was that I didn't edit a few files in the image, as outlined here.

Once I did that, it booted fine.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.