1

I'm writing this after days of search and incomprehensions. I already tried asking my question on the Mint forums but I've got no help yet and I prefer asking for more advices, that could lead to a faster answer.

I used to be on Mint 17.1 (or .2 I forgot) before and the proprietary nvidia driver was working. I had the 340 or 346 one, I can't really remember. I also had the xorg and kernel shipped in with that version of Mint. Everything was working fine.

So, a few days ago I noticed the 17.3 update and did it. I noticed in the changelog that there was this new driver-switcher and told myself it was time to upgrade my nvidia driver. But since then, none of them are working. Only the nouveau driver or intel's ones are working.

Oh yeah, I forgot to mention it's a laptop having both an Intel chipset and an Nvidia card working with optimus (well it should).

Here's the lspci -vnn | grep '\''[030[02]\]' output:

00:02.0 VGA compatible controller [0300]: Intel Corporation 4th Gen Core Processor Integrated Graphics Controller [8086:0416] (rev 06) (prog-if 00 [VGA controller])
01:00.0 3D controller [0302]: NVIDIA Corporation GM108M [GeForce 840M] [10de:1341] (rev a2)

Since then, I tried to update both my kernel and my xorg, to be sure it's not the problem but it didn't help.

So now, I'm running the 4.4.0-15-generic kernel version with the 1.18.3 version of Xorg.

Here's the /var/log/Xorg.0.log (paste.bin, too long for this forum) when I try to make my laptop start with the nvidia-361 driver. Notice that no error is output.

I tried a few version numbers: 340, 346, 352, 361 but none are working. I have considered using the nvidia .run script but I'd like to have tried everything to make the package installation work first.

Also, if it can help, the output of inxi -Fxz (don't mind the "failed: nouveau", it's currently uninstalled):

System:    Host: msiniwa Kernel: 4.4.0-15-generic x86_64 (64 bit gcc: 4.8.2)
           Desktop: Cinnamon 2.8.8 (Gtk 3.10.8~8+qiana) Distro: Linux Mint 17.3 Rosa
Machine:   Mobo: Micro-Star model: MS-16GH v: REV:1.0 Bios: American Megatrends v: E16GHIMS.10H date: 12/25/2014
CPU:       Dual core Intel Core i5-4210H (-HT-MCP-) cache: 3072 KB
           flags: (lm nx sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx) bmips: 11572
           clock speeds: max: 3500 MHz 1: 3376 MHz 2: 2900 MHz 3: 2900 MHz 4: 3306 MHz
Graphics:  Card-1: Intel 4th Gen Core Processor Integrated Graphics Controller bus-ID: 00:02.0
           Card-2: NVIDIA GM108M [GeForce 840M] bus-ID: 01:00.0
           Display Server: X.Org 1.18.3 drivers: intel (unloaded: fbdev,vesa) FAILED: nouveau
           Resolution: 1366x768@60.0hz
           GLX Renderer: Mesa DRI Intel Haswell Mobile
           GLX Version: 3.0 Mesa 11.3.0-devel (git-30b818d 2016-04-09 trusty-oibaf-ppa) Direct Rendering: Yes
Audio:     Card-1 Intel 8 Series/C220 Series High Definition Audio Controller
           driver: snd_hda_intel bus-ID: 00:1b.0
           Card-2 Intel Xeon E3-1200 v3/4th Gen Core Processor HD Audio Controller
           driver: snd_hda_intel bus-ID: 00:03.0
           Sound: Advanced Linux Sound Architecture v: k4.4.0-15-generic
Network:   Card-1: Qualcomm Atheros Killer E220x Gigabit Ethernet Controller
           driver: alx port: d000 bus-ID: 03:00.0
           IF: eth0 state: up speed: 100 Mbps duplex: full mac: <filter>
           Card-2: Intel Wireless 3160 driver: iwlwifi bus-ID: 05:00.0
           IF: wlan0 state: up mac: <filter>
Drives:    HDD Total Size: 750.2GB (75.6% used) ID-1: /dev/sda model: WDC_WD5000LPVX size: 500.1GB
           ID-2: /dev/sdb model: Samsung_SSD_840 size: 250.1GB
Partition: ID-1: / size: 225G used: 114G (54%) fs: ext4 dev: /dev/sdb3
           ID-2: /boot size: 283M used: 171M (65%) fs: ext4 dev: /dev/sdb1
           ID-3: swap-1 size: 15.73GB used: 0.00GB (0%) fs: swap dev: /dev/sda2
           ID-4: swap-2 size: 4.19GB used: 0.00GB (0%) fs: swap dev: /dev/sdb4
RAID:      No RAID devices: /proc/mdstat, md_mod kernel module present
Sensors:   System Temperatures: cpu: 61.0C mobo: N/A
           Fan Speeds (in rpm): cpu: N/A
Info:      Processes: 362 Uptime: 3:59 Memory: 2847.6/11934.9MB Init: Upstart runlevel: 2 Gcc sys: 4.8.4
           Client: Shell (bash 4.3.111) inxi: 2.2.28

I'm probably missing something but I can't find what.

I'm an experienced user, don't hesitate to be technical!

Thank you a lot for your future help!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.