2

I'm trying to setup Samba on a Linux Mint 17.3 install. My /etc/samba/smb.conf file is at: http://pastebin.com/FvaK7Yq5

When I try to access the share \\192.168.1.2\jezhome, I use the username WORKGROUP\jez and the correct passsword, yet in the Samba logfile I get the message "guest user (from session setup) not permitted to access this share (jezhome)". But why is it trying to access the share as a guest user? I don't get it. There is nothing in there about the "jez" user I am trying to log in as. I tried clearing these credentials in Windows and logging in again but I get the same deal. Any ideas?

2

this would be consistent with unsuccessful authentication attempt?

# This option controls how unsuccessful authentication attempts are mapped
# to anonymous connections
   map to guest = bad user

please post logfile showing your authentication succeeding or otherwise

  • Wow thanks for that, it was indeed causing the weird behaviour. What an unintuative default! Oh and after that, I had to create the Samba user with smbpasswd to get it to log in. – Jez Apr 11 '16 at 21:16
  • This was very helpful in pointing me in the correct direction. I needed to run smbpasswd -a username and that resolved this issue for me. – tufelkinder Mar 19 '18 at 22:36
2

other useful information is to add the user to the unix box first with useradd, and add them to your samba users group (or additional groups depending on privileges of the user) with usermod -G.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.