1

I have been doing lots of testing of ZFS recently on a new server.

I'm ready to move this server into production now, but I'm wondering if I can get rid of my old 'faulted' diskpools before I do, for tidyness more than anything else.

so if i run zpool import, I see the following...

[root@localhost /]# zpool import
 pool: diskpool
 id: 18370547499919589045
 state: UNAVAIL
 status: One or more devices contains corrupted data.
 action: The pool cannot be imported due to damaged devices or data.
 see: http://zfsonlinux.org/msg/ZFS-8000-5E
config:

    diskpool                              UNAVAIL  insufficient replicas
      raidz2-1                            UNAVAIL  insufficient replicas
        ata-ST8000AS0002-1NA17Z_Z840DNW0  FAULTED  corrupted data
        ata-ST8000AS0002-1NA17Z_Z840DG92  ONLINE
        ata-ST8000AS0002-1NA17Z_Z840DT6G  FAULTED  corrupted data
        ata-ST8000AS0002-1NA17Z_Z840DVJ2  FAULTED  corrupted data
        ata-ST8000AS0002-1NA17Z_Z840DLL4  FAULTED  corrupted data
        ata-ST8000AS0002-1NA17Z_Z840DLVR  FAULTED  corrupted data
        ata-ST8000AS0002-1NA17Z_Z840DLPB  FAULTED  corrupted data
        ata-ST8000AS0002-1NA17Z_Z840DAMG  FAULTED  corrupted data
        ata-ST8000AS0002-1NA17Z_Z840DCEN  FAULTED  corrupted data
        ata-ST8000AS0002-1NA17Z_Z840DA8Q  FAULTED  corrupted data
        ata-ST8000AS0002-1NA17Z_Z840DAXK  FAULTED  corrupted data
        ata-ST8000AS0002-1NA17Z_Z840D27A  FAULTED  corrupted data
        ata-ST8000AS0002-1NA17Z_Z840DA95  FAULTED  corrupted data
        ata-ST8000AS0002-1NA17Z_Z840DFEK  FAULTED  corrupted data
        ata-ST8000AS0002-1NA17Z_Z840DA6R  FAULTED  corrupted data
        ata-ST8000AS0002-1NA17Z_Z840DSWR  FAULTED  corrupted data
        ata-ST8000AS0002-1NA17Z_Z840DNNN  FAULTED  corrupted data
        ata-ST8000AS0002-1NA17Z_Z840CVPT  FAULTED  corrupted data
        ata-ST8000AS0002-1NA17Z_Z840DNKW  FAULTED  corrupted data
        ata-ST8000AS0002-1NA17Z_Z840DNPK  FAULTED  corrupted data

I tried to remove 'diskpool' with zpool destroy diskpool, to no avail...

[root@localhost /]# zpool destroy diskpool
cannot open 'diskpool': no such pool

I've rebooted and done most everything I can think of, but its not letting me bin off this old data.

I know I can essentially ignore it, as once I create my production pool, it will just be old data thats irrelevant, but it would be nice if I could remove it.

Any ideas?

| improve this question | | | | |
  • 1) Just overwrite the disks (e.g. with zeros) to get rid of all data. 2) I hope this was just for testing and you're not intending to run a 20-disk wide vdev in production, which is way too large. Split it up into at least 2 vdevs. – Marco Apr 11 '16 at 15:57
  • I'm actually running 3 nested vdevs in a 60 disk pool, all RAIDZ2 :) – John Apr 12 '16 at 7:44
  • 2
    ZFS doesn't support nested vdevs. Vdevs can only contain files or disks, not other vdevs. And as I said, a 20 disk wide vdev is too wide for a production server. – Marco Apr 12 '16 at 8:07
  • 1
    To reiterate what @Marco says: 20 drives in a RAIDZ2 vdev is going to have unacceptable rebuild/scrub times, especially given the drives are not just 8 TB each, they're 8 TB and slow - at 5900 RPM, they can probably only do about 50-60 IO ops per second. And backups? RAID is not a backup. You have 60 huge, slow drives and only 6 "parity drives" and no spares. Depending on usage, if it's a general-purpose file store I'd build it with 4+1 RAIDZ (not RAIDZ2) vdevs to better handle smaller-block IO, with 5 spares. – Andrew Henle Apr 13 '16 at 12:20
1

It looks like the only disk that remembers the "diskpool" pool is ata-ST8000AS0002-1NA17Z_Z840DG92, so what you can do is overwrite the label on that disk:

# zpool create -f foo ata-ST8000AS0002-1NA17Z_Z840DG92
# zpool destroy foo

That should prevent the "zpool import" command from seeing the long-defunct diskpool. Be careful to make sure that ata-ST8000AS0002-1NA17Z_Z840DG92 is not being used by any other pool in your system, first.

| improve this answer | | | | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.