1

I always run Windows 10 (Ethernet and WiFi work fine) but I dual boot and changed my distro from Arch (~6 months ago) to Fedora (~3 months ago). Fedora used to connect sometimes and sometimes not. However, now it won't connect at all. Antergos won't. Debian won't. Arch won't. Fedora won't.

I've reset my router and modem and I've even tried this at another house and it still doesn't connect. If I set a static IP, it "connects", but I still can't access the internet. Pinging google or even my own router doesn't work (destination host unreachable). Any help?

lspci | egrep -i --color 'network|ethernet'

00:19.0 Ethernet controller: Intel Corporation Ethernet Connection I217-LM
03:00.0 Network controller: Realtek Semiconductor Co., Ltd. RTL8723BE PCIe Wireless Network Adapter

There are also only Windows drivers for my Ethernet on my MB.

edit: attempt at installing ethernet driver on Antergos installation

tar zxf e1000e-3.3.3.tar.gz
cd e1000e-3.3.3/src/
sudo make install
Makefile 67: *** Kernel header files not in any of the expected locations.
Makefile 68: *** Install the appropriate kernel development package.  e.g.
Makefile 69: *** kernel-devel.  for building kernel modules and try again.  Stop.

edit 2: successfully installed the e1000e driver, still can't connect. Same error as before, "unknown host" if DHCP enabled, "destination host unreachable" if IP is static.

edit 3:

cp /etc/network/interfaces /etc/network/interfaces-old
service networking stop
nano /etc/network/interfaces

added these to interfaces:

allow-hotplug eth0
iface eth0 inet dhcp

and then:

ifdown eth0
ifup eth0

The result was:

DHCPDISCOVER on eth0 to 255.255.255.255 port 67 interval 7
DHCPDISCOVER on eth0 to 255.255.255.255 port 67 interval 12
DHCPDISCOVER on eth0 to 255.255.255.255 port 67 interval 13
DHCPDISCOVER on eth0 to 255.255.255.255 port 67 interval 14
DHCPDISCOVER on eth0 to 255.255.255.255 port 67 interval 9
DHCPDISCOVER on eth0 to 255.255.255.255 port 67 interval 6
No DHCPOFFERS received.
No working leases in persistent database - sleeping.
grep: /etc/resolv.conf: No such file or directory

I then created a resolv.conf, added Google DNS and their alternate as nameservers, and I got the exact same result after ifdown eth0 and ifup eth0 as before (besides the different intervals), except the resolv.conf error was no longer there. This post on UbuntuForums seems to describe my problem exactly.

edit 4: solution

Hello from Antergos! I figured it out through a strange pattern. If my computer is off and and I turn it on, and boot DIRECTLY into Antergos (or any distro I suppose), my ethernet and wifi work! However, if I boot into Windows first and then restart (not turn off and turn on, just the "restart" option where Windows handles it), my cards do not work. I'm guessing Windows has some strange way of restarting that causes a conflict with Linux. I wish I could figure out a way to restart within Windows and have it still work but I guess it really doesn't matter, it's only an extra 5 seconds or so. Thanks everyone for your help though, I learned a ton about Linux! I'm going to keep this unsolved unless someone knows how to fix it for good, but for now, internet seems to be working.

  • Please edit and add the the ouput of lspci | egrep -i --color 'network|ethernet' – GAD3R Apr 11 '16 at 0:14
  • Done. Are the two supposed to be the same? – shneap Apr 11 '16 at 0:33
  • the 1st ethernet and the second wifi – GAD3R Apr 11 '16 at 0:49
  • So this still works on the same hardware in Windows, but it does not work in any Linux install you try? If you set a static IP and it "connects", does the router see your device? Can you successfully ping 127.0.0.1? – Ryan Apr 11 '16 at 1:37
  • @Ryan I'll check tomorrow. What I mean when it "connects" is it says it's connected, but I still get destination host unreachable. – shneap Apr 11 '16 at 2:11
1

You need to install linux-headers , linux-headers-generic, build-essential and dkms , visit AskUbuntu-How to install software or packages without Internet

To install Ethernet controller download e1000e.x.x.x.tar.gz from here

and type the following command

tar zxf e1000e-<x.x.x>.tar.gz
cd e1000e-<x.x.x>/src/
sudo make install
modprobe e1000e

Verify your internet connection and install the wifi driver using the following command:

git clone https://github.com/lwfinger/rtlwifi_new.git
cd rtlwifi_new
make
sudo make install
sudo modprobe rtl8723be

To avoid the same problem , the easy way is to be connected to the internet during the OS install.

edit

backup interfaces

cp /etc/network/interfaces /etc/network/interfaces-old

then type:

service networking stop

edit interfaces

nano /etc/network/interfaces

add the following lines;

allow-hotplug eth0
iface eth0 inet dhcp

And

ifdown eth0
ifup eth0
  • Shouldn't I be connected though? I don't understand why it's not connecting me in the first place. Thanks for the help though, I'll try it out later tonight if I have time. – shneap Apr 11 '16 at 1:21
  • I extracted the .tar off of a USB into my ~, cd in the /src/ of it, but when I sudo make install, I got this error (edited it into the main post). I'm quite new to Linux so sorry if these problems seem petty. – shneap Apr 11 '16 at 5:10
  • Still says network unreachable when I try to ping anything but 127.0.0.1 – shneap Apr 11 '16 at 22:19
  • Edited the main post with what you said. This thread seems to be explaining exactly what I'm experiencing (even the same card) ubuntuforums.org/showthread.php?t=1021585 – shneap Apr 13 '16 at 1:28
  • Make sur that wpa_supplicant is installed and try to connect to wifi using systemd networkd unix.stackexchange.com/a/266523/153195 – GAD3R Apr 13 '16 at 12:50
0

Only as information for manually setting IPs. It is not enough to set an IP. You also need a routing entry like:

ip route add default via YOUR-ROUTER-IP dev YOUR-ETH-DEVICE

additional Info

For manual network settings there will be 2 options.
1) without installed packages to manage resolv.conf

  • edit /etc/networ/interfaces and modyfy/insert as follows:
    auto eth0 iface eth0 inet static address YOUR-IP netmask YOUR Netmask gateway YOUR GW

  • edit /etc/resolv.conf and make an entry like this:

    nameserver YOUR-Nameserver (normally the IP of your provider router/default GW)

2) with packages like openresolv, or resolvconf (Debian names) installed

  • edit /etc/networ/interfaces and modyfy/insert as follows: auto eth0 iface eth0 inet static address YOUR-IP netmask YOUR Netmask gateway YOUR GW dns-nameservers YOUR-Nameserver

In both cases you don't need to set the default route as noted above. That was only for testing.
So here are a few commands to see whats going on:
ip link show (displays the link status of the NIC)
ip address show (displays the IP addresses)
ip route show (displays all routes configured)

If you "ping" a hostname unsuccessful, try "nslookup hostname" and see if the hostname could be resolved to an IP.

  • Adding the routing entry didn't seem to do anything (still getting destination host unreachable). Thanks for the future info though, never knew about setting the route. – shneap Apr 11 '16 at 22:42
  • Sorry, that was just a quick answer. I missed something important, if you try to use hostnames instead of IP-Addresses. Then you also need to set a nemserver entry in /etc/resolv.conf. That is normally also the IP of your default gateway (provider router). For better formatting I'll edit the answer, and put some additional information. – Winnie Tigger Apr 13 '16 at 7:21
  • Followed that and still couldn't look up a hostname. I tried this after doing what GAD3R suggested so maybe that conflicted with this, not really sure. – shneap Apr 13 '16 at 19:21
  • Not really. The only conflicting part is "iface eth0 inet dhcp" in interfaces file. But I assume that you have changed that as in my answer. What about ping to IPs? Does this work? – Winnie Tigger Apr 14 '16 at 10:04
  • I added the solution in the main post. It was very strange... – shneap Apr 14 '16 at 15:01

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.