0

I am trying to access my Centos 7 server's desktop so I installed ...

[plankton@localhost ~]$ rpm -q --info tigervnc-server
Name        : tigervnc-server
Version     : 1.3.1
Release     : 4.el7_2
Architecture: x86_64
Install Date: Sat 09 Apr 2016 07:37:13 PM PDT
Group       : User Interface/X
Size        : 504777
License     : GPLv2+
Signature   : RSA/SHA256, Thu 31 Mar 2016 01:14:19 PM PDT, Key ID 24c6a8a7f4a80eb5
Source RPM  : tigervnc-1.3.1-4.el7_2.src.rpm
Build Date  : Thu 31 Mar 2016 09:35:08 AM PDT
Build Host  : worker1.bsys.centos.org
Relocations : (not relocatable)
Packager    : CentOS BuildSystem <http://bugs.centos.org>
Vendor      : CentOS
URL         : http://www.tigervnc.com
Summary     : A TigerVNC server
Description :
The VNC system allows you to access the same desktop from a wide
variety of platforms.  This package includes set of utilities
which make usage of TigerVNC server more user friendly. It also
contains x0vncserver program which can export your active
X session.

Then I started the vncserver like so:

[plankton@localhost ~]$ vncserver

You will require a password to access your desktops.

Password:
Verify:
xauth:  file /home/plankton/.Xauthority does not exist

New 'localhost.localdomain:1 (plankton)' desktop is localhost.localdomain:1

Creating default startup script /home/plankton/.vnc/xstartup
Starting applications specified in /home/plankton/.vnc/xstartup
Log file is /home/plankton/.vnc/localhost.localdomain:1.log

vncserver -list has this output:

[plankton@localhost ~]$ vncserver -list

TigerVNC server sessions:

X DISPLAY #     PROCESS ID
:1              6488

On my windows 10 system I install the vnc client from here: https://www.realvnc.com/download/get/1861/

when I try to connect from my windows system to my Centos 7 server I get this error.

enter image description here

I have disabled selinux, and execute iptables --flush as root and I am using the correct IP address. I do not get prompted for a password. Can anyone help me out?

Thanks

1

Oops! I needed to specify the port 5901 like so:

enter image description here

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.