1

Situation:

I am on Linux Mint 17.3 and have on the station auto-login enabled. I have an SSH key in gnome-keyring.

Objective:

I would like the SSH keyring not to ask me for password. I am aware it might pose a security risk, but this question is not about that.

0

Solution:

  1. disable auto-login, I thought of this anyway
  2. logout and login again
  3. the next time I tried to connect to SSH there was a checkbox to automatically unlock this key, which I ckecked and proceeded with login
  4. voila!, after reboot I have increased security by disabling the auto-login and it does not ask me for password on SSH keyring

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.