I am using arch linux and i was using pulseaudio suddenly today pulseaudio stopped working and no sound is coming in both my speaker and headphone. I can see pulseaudio is running properly and I am able to hear the beep sound from my computer but not any other sound??? any suggestions please I had already read the wiki page. I run pulseaudio as root and I had added my root in audio group

  • there are a lot of reasons why pulseaudio might stop working. be more specific, especially on what you mean with 'suddenly'. – Baarn Dec 23 '11 at 20:38
  • till yestarday it was working fine but today when i switched on my computer sound is not coming. It is not a hardware problem as I am able to hear sound in windows OS in my pc – harish.venkat Dec 23 '11 at 20:52
  • finally it started to work i changed configuration in /etc/pulse/daemon.conf(commented every line in it) and the sound started to work and i found that my system sound was set to zero and i increased it and it works now thanks for everyone – harish.venkat Dec 28 '11 at 14:19
  • 1
    @Informaficker "suddenly" means, everything is working fine, music is playing, you're working in some other application (not touching the music player program), nothing out of the ordinary, then pulseaudio just suddenly goes silent for no apparent reason. Of course, if you wasted your time filing a bug against pulseaudio, they would blame something else like the music player, or the audio driver, or have some other excuse. They would never even consider that their precious pulseaudio was anything less than perfect. That's what's wrong with pulseaudio. – doug65536 Jun 14 '13 at 17:22

Just kill the pulseaudio process, and re-launch it would be fine:

killall -9 pulseaudio; pulseaudio

For that reason I no longer uses pulseaudio on my system, I fallback to alsa now.

P.S some app can specify which sound output to use, e.g mplayer, what application that doens't produce sound that you're using?

  • 1
    warl0ck: yes, I also use alsa now and it works fine for me – harish.venkat Sep 22 '12 at 17:13

First, let me recommend installing pavumeter, which lets you see the in/out levels that pulse thinks are happening.

My guess is that something came unstuck in your ALSA configuration. I'm not really sure what Pulse's view of audio architecture is, but I find that I normally have to twiddle settings with 'alsamixer' to make a linux desktop's audio work right. (For instance, mic being mixed into output, or the wrong inputs or outputs, etc). Make sure you look at all the "soundcards" alsamixer shows, and both the rx and tx channels.

I guess it would also be useful to know what you mean by being able to hear the beep. Do you mean from the motherboard speaker?

  • yes, the sound is from motherboard speaker and also I have installed pavumeter and it is showing that sound is being played but no sound through speakers or headphone, alsamixer is working fine. – harish.venkat Dec 23 '11 at 20:48

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.