1

Why this strange behavior is happening and how to fix it?

Details:

I have configured fallback Glagolitic font in fonts.conf:

<alias>
    <family>sans-serif</family>
        <prefer>
            ...
            <family>Noto Sans Glagolitic</family>
            ...
        </prefer>
    </family>
</alias>

And this works as expected everywhere:

Everything is fine

Except the firefox, which render chars in FreeSans for some reason. BUT if I set a font-weight to bold it's choose the right font:

enter image description here

This is make no sense because 'Noto Sans Glagolitic' is not a bold font but a regular one:

$ fc-cat | grep Glagol
"NotoSansGlagolitic-Regular.ttf" 0 "Noto Sans Glagolitic:
familylang=en:style=Regular:stylelang=en:fullname=Noto Sans Glagolitic:
fullnamelang=en:slant=0:weight=80:width=100:...

It doesn't even have bold version! (It had tried to autobold it, but I have disabled this)

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.