3

I am trying to install the new OpenSuse Leap 42.1 on my PC. I already tried 4 different installation mediums:

  • DVD with full installation
  • DVD with Net installation
  • USB with full installation
  • USB with Net installation

For all of them I receive the exact same result: While initializing the installation process, it hangs at "Starting udev...". The first minute or so the cursor at the end of that line is blinking, but after a minute or two even the cursor stops blinking.

I already tried all of the available options, like text mode, no KSM, Safe Settings and so on. But nothing changed the result, for no setup device. The only thing which happened when I set the kernel settings to No Local APCI is the following:
First it showed "Switching to clock source tsc" for a long time (probably 5 minutes or so). Then it added "random: nonblocking pool is initialized" to the output, but after that nothing happened.

For my setup: I have a i7-3770 processor, a radeon HD 7970,16GB DDR-3 RAM, ASRock H77 Pro4/MVP Mainboard, one 128GB SSD with Windows 10 installed, a 1TB HDD with data, games and programs (all for windows) and one empty 500GB HDD which I would like to use for OpenSuse.

I had an older version of OpenSuse already running two years ago on this computer.

Can someone provide me a solution to this problem or help me narrowing its cause, please? If you need some additional information I can provide those, but I could currently not think of any other important information.

2
  • Shot in the dark: Try disabling acpi, or setting noapic when booting.
    – choroba
    Commented Apr 7, 2016 at 19:32
  • Hey. Thank you, already did that twice. Once with the setting in the UI (F5 I think) and once both together via the boot parameter input. Same result. Commented Apr 7, 2016 at 20:13

3 Answers 3

0

Had a similar problem on system with nvidia card. Try setting nomodeset option. After installation install nvidia drivers.

1
  • Hey. Thanks for that tip. I read that this usually helps, but in my case I could even try text only mode and it did not change the problem. Commented May 29, 2016 at 8:32
0

I actually figured out the solution to this weird problem and the solution is equally weird:

I had to plug in the DVD drive in another SATA slot. I have two places on my motherboard with SATA slots: A group of two SATA slots and another group of 8 SATA slots and the DVD drive was plugged in on of the slots in the group of two. After plugging it into a slit on the group of eight, where also all the hard drives are connected, the error did not occur anymore and I was able to install opensuse (and also every other distribution as all of them did not install before) without any special settings.

0

I hit exactly the same problem, install hangs on udev, however I discovered an interesting solution. The beta release of 42.2 does not have this problem and installs sucessfully. The udev step does take ages but it completes. With the system installed it does boot up quickly.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .