0

I have a desktop computer which I run mostly with a wired network connection. When I start the Wicd network manager it says "No wireless networks found." Also, the command iwlist gives the same result:

# iwlist scan
eth0      Interface doesn't support scanning.

wlan0     No scan results

lo        Interface doesn't support scanning.

I have installed the driver for my network card firmware-b43-installer and I know that Wi-Fi has worked previously. My router is located nearby and several other wireless devices are connected to it. Any clues?

Edit:

The output of rfkill indicates that Wi-Fi is enabled:

# rfkill list all
0: hci0: Bluetooth
        Soft blocked: no
        Hard blocked: no
1: phy0: Wireless LAN
        Soft blocked: no
        Hard blocked: no

Edit 2:

Here is some information about the wireless network card:

$ lspci -nn | grep Network
03:00.0 Network controller [0280]: Broadcom Corporation BCM4321 802.11a/b/g/n [14e4:4328] (rev 05)

$ lspci -knn | grep Net -A2
03:00.0 Network controller [0280]: Broadcom Corporation BCM4321 802.11a/b/g/n [14e4:4328] (rev 05)
        Subsystem: Apple Inc. AirPort Extreme [106b:0090]
        Kernel driver in use: b43-pci-bridge
  • are you sure that wifi on your machine is enabled. sometimes there is a button some where that needs to be pushed. – Ijaz Ahmad Khan Apr 6 '16 at 11:05
  • @ljaz I have a Mac Mini and I'm not aware of any such button. Is there a way to tell if Wi-Fi s enabled? – August Karlstrom Apr 6 '16 at 11:57
  • use rfkill. You might need to install it. – Ralph Rönnquist Apr 6 '16 at 12:06
  • @RalphRönnquist I have added the output of rfkill list and if I'm not mistaken it says that Wi-Fi is enabled. – August Karlstrom Apr 6 '16 at 13:40
  • the output of lspci -nn | grep Network and your Linux dist – GAD3R Apr 6 '16 at 14:01
0

The command lspci -knn | grep Net -A2 will give you the information about the Kernel driver in use. According to debian_wl , you need to use wl module

Edit sources.list :

apt edit-sources

choose nano and add 'non-free sources' :

# Debian 8 "Jessie"
deb http://httpredir.debian.org/debian/ jessie main contrib non-free

Update package:

aptitude update

We need to install broadcom-sta-dkms and linux-headers

Insert the cd-rom and type:

apt-get install linux-image-$(uname -r|sed 's,[^-]*-[^-]*-,,') linux-headers-$(uname -r|sed 's,[^-]*-[^-]*-,,') broadcom-sta-dkms

Unload conflicting modules:

modprobe -r b44 b43 b43legacy ssb brcmsmac bcma

Load the right module wl:

modprobe wl

Next step you need to unistall network-manager Or wicd

| improve this answer | |
  • Thanks for your answer. However, today it just works (like before) and I haven't done any changes (no broadcom-sta-dkms or linux-headers installed). I wonder what went wrong previously. – August Karlstrom Apr 8 '16 at 13:15

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.