2

I've installed Terminator from the homebrew/gui tap, but when I ran it, it raised this error:

You need to install the python bindings for gobject, gtk and pango to run Terminator.

I edited /usr/local/bin/terminator (it's just Python) to display the error message, and I got this:

dlopen(/usr/local/lib/python2.7/site-packages/glib/_glib.so, 2): Library not loaded: /usr/local/lib/libgobject-2.0.0.dylib
  Referenced from: /usr/local/lib/python2.7/site-packages/glib/_glib.so
  Reason: Incompatible library version: _glib.so requires version 4401.0.0 or later, but libgobject-2.0.0.dylib provides version 3401.0.0

The fact that this is showing up does not surprise me, as I've had a similar error with pretty much every Python program that uses GTK.

Let me know if I should ask on Ask Different instead.

  • Have you raised this on the tap's issue tracker? It sounds like a packaging bug to me. – Xiong Chiamiov Apr 6 '16 at 18:28
  • It's not an issue with the tap, I get this error with all Python programs using GTK. – Samadi Apr 6 '16 at 23:24
  • Then it's probably an issue with one of the common dependencies, which is still homebrew-packaged. – Xiong Chiamiov Apr 7 '16 at 18:18

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.