6

I am running Debian Jessie on VMWare, and the default resolution is 800x600. I can set it to 1360x768 with xrandr, but next time I log in it's still 800x600.

Some posts on the internet said to edit my xorg.conf file. I ran Xorg -configure, and got an xorg.conf.new file. I tried testing it, but the screen remains black (running startx without the config works fine).

Some other post said to edit the display.xml file in this directory (.config/xfce4/xfconf/xfce-perchannel-xml), but I don't have a display.xml file.

Any idea how to do this?

Log file: http://pastebin.com/YaFrfnum

Conf file: http://pastebin.com/nYGg06TJ

  • Post the xorg.conf file and the error messages in /var/log/Xorg.0.log when X fails to start. – L. Levrel Apr 5 '16 at 19:02
  • have you tried to use xfce4-display-settings to change xfce resolution? – Scantlight Apr 5 '16 at 19:51
  • Are you sure it's the log of the failing X? It shows no error. Also, your xorg.conf does not specify your preferred resolution. Add Option "PreferredMode" "1360x768" in the Monitor section. – L. Levrel Apr 5 '16 at 19:52
  • @L.Levrel It shows now error because it didn't really fail. It just stayed black until I went back to the console with Ctrl+Alt+F1 and closed it with Ctrl+C – devil0150 Apr 5 '16 at 19:58
  • @Scantlight that worked thank you. Can you write it as an answer? – devil0150 Apr 5 '16 at 19:59
5

One of many ways to change settings in a desktop environment is to use tools that are provided with that environment. In this case XFCE is a desktop environment and it offers such tools, some with graphical interface.

And the simplest way to change resolution is to use "Display" that can be found under Application Menu > Settings > Display or it can be invoked from terminal emulator using xfce4-display-settings command.

Of course if you do not like a graphical solution, you alway can manually modify the respective file (in this case .config/xfce4/xfconf/xfce-perchannel-xml/displays.xml)

  • and how would one apply these settings after file modification? – Blauhirn Oct 11 '17 at 14:40
  • I don't find displays.xml file. How can i always set 1360x768 resolution using command line? Default is 640 something which is very very narrow. – Jitesh Sojitra Mar 24 '18 at 5:20
4

Two problems I had to solve in my setup (OpenSuse as VMware guest):

  1. the resolution is not in the dropdown list of xfce4-display-settings (but the name of the monitor is. You'll need it later).
  2. every logout 'forgets' the manually added resolution (via xrandr)

My procedure for the monitor ('Virtual1'), which I want to set to 1160x1600:

On the target monitor determine the timing parameters

$ cvt 1160 1600
# 1160x1600 59.99 Hz (CVT) hsync: 99.46 kHz; pclk: 156.75 MHz
Modeline "1160x1600_60.00"  156.75  1160 1248 1368 1576  1600 1603 1613 1658 -hsync +vsync
$ _

Activate that modeline using xrandr:

$ xrandr --newmode "1160x1600_60.00"  156.75  1160 1248 1368 1576  1600 1603 1613 1658 -hsync +vsync
$ xrandr --addmode Virtual1 1160x1600_60.00
$ xrandr --output  Virtual1 --mode 1160x1600_60.00
$ _

Voila!

In order to get this screen resolution automatically at login, add the above 'xrandr' lines to .bashrc or .profile.

This cludge works for me. Perhaps someone knows where best to change the system configuration to make it permanent, even surviving updates? (All my old *nix know-how seems to be obsolete since systemd...)

"Those who do not understand Unix are condemned to reinvent it, poorly. - Henry Spencer"

0

I had the same issue with absent of supported resolutions in the screen settings list. I solve this issue by set proper limits for Sync and Refresh variables in my xorg.conf:

HorizSync 31.0 - 83.0

VertRefresh 56.0 - 75.0

The actual values I've got from my LCD datasheet. I'm using Iiyama ProLite E2001WSV monitor.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.