0

I'm trying to install GNU screen:

sudo apt-get install screen

I receive following:

Reading package lists... Done
Building dependency tree       
Reading state information... Done
You might want to run 'apt-get -f install' to correct these:
The following packages have unmet dependencies:
 printer-driver-gutenprint : Depends: cups (>= 1.3.0)
 printer-driver-splix : Depends: cups (>= 1.5.0-3~)
E: Unmet dependencies. [u]Try 'apt-get -f install' with no packages[/u] (or specify a solution).

Next I execute:

sudo apt-get -f install
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Correcting dependencies... Done
The following extra packages will be installed:
  cups-bsd cups-client cups-common libcups2 libcups2:i386 libcupscgi1
  libcupsimage2 libcupsimage2:i386 libcupsmime1 libcupsppdc1 libgmp10
  libgmp10:i386 libgnutls-deb0-28 libgnutls-deb0-28:i386 libhogweed2
  libhogweed2:i386 libnettle4 libnettle4:i386 libp11-kit-dev libp11-kit0
  libp11-kit0:i386 libtasn1-6 libtasn1-6:i386 libtasn1-6-dev p11-kit-modules
Suggested packages:
  cups xpp gnutls-bin gnutls-bin:i386
Recommended packages:
  libtasn1-doc
The following packages will be REMOVED:
  cups-core-drivers cups-daemon printer-driver-gutenprint printer-driver-splix
The following NEW packages will be installed:
  libgmp10:i386 libgnutls-deb0-28 libgnutls-deb0-28:i386 libhogweed2:i386
  libnettle4:i386
The following packages will be upgraded:
  cups-bsd cups-client cups-common libcups2 libcups2:i386 libcupscgi1
  libcupsimage2 libcupsimage2:i386 libcupsmime1 libcupsppdc1 libgmp10
  libhogweed2 libnettle4 libp11-kit-dev libp11-kit0 libp11-kit0:i386
  libtasn1-6 libtasn1-6:i386 libtasn1-6-dev p11-kit-modules
20 upgraded, 5 newly installed, 4 to remove and 1809 not upgraded.
1 not fully installed or removed.
Need to get 0 B/3284 kB of archives.
After this operation, 3698 kB of additional disk space will be used.
Do you want to continue? [Y/n] y
Preconfiguring packages ...
Setting up fontconfig (2.11.1-0ubuntu6) ...
Regenerating fonts cache... failed.
See /var/log/fontconfig.log for more information.
dpkg: error processing package fontconfig (--configure):
 subprocess installed post-installation script returned error exit status 1
Errors were encountered while processing:
 fontconfig
E: Sub-process /usr/bin/dpkg returned an error code (1)

And I can't install updates from Update manager - it throws alerts about " printer drivers packages have mistakes"

How to fix this?

/var/log/fontconfig.log:

[...]
/usr/local/share/fonts: caching, new cache contents: 0 fonts, 0 dirs
/.local/share/fonts: skipping, no such directory
Re-scanning /usr/share/fonts: fc-cache: symbol lookup error: fc-cache: undefined symbol: FcDirCacheRescan

ldd /usr/bin/fc-cache (sory I'm not sure, should I include the whole log):

linux-vdso.so.1 =>  (0x00007fffcad59000)
    libfontconfig.so.1 => /usr/lib/x86_64-linux-gnu/libfontconfig.so.1 (0x00007f5b50e3c000)
    libpthread.so.0 => /lib/x86_64-linux-gnu/libpthread.so.0 (0x00007f5b50c1e000)
    libc.so.6 => /lib/x86_64-linux-gnu/libc.so.6 (0x00007f5b50858000)
    libfreetype.so.6 => /usr/lib/x86_64-linux-gnu/libfreetype.so.6 (0x00007f5b505b5000)
    libexpat.so.1 => /lib/x86_64-linux-gnu/libexpat.so.1 (0x00007f5b5038b000)
    /lib64/ld-linux-x86-64.so.2 (0x000056140f1b3000)
    libz.so.1 => /lib/x86_64-linux-gnu/libz.so.1 (0x00007f5b50171000)
    libpng12.so.0 => /lib/x86_64-linux-gnu/libpng12.so.0 (0x00007f5b4ff4b000)
    libm.so.6 => /lib/x86_64-linux-gnu/libm.so.6 (0x00007f5b4fc45000)

head -n 50 /etc/apt/sources.list /etc/apt/sources.list.d/*.list :

==> /etc/apt/sources.list <==
#deb cdrom:[Linux Mint 17 _Qiana_ - Release amd64 20140624]/ trusty contrib main non-free
deb http://cz.archive.ubuntu.com/ubuntu vivid main universe

==> /etc/apt/sources.list.d/additional-repositories.list <==
deb http://cz.archive.ubuntu.com/ubuntu vivid main universe

==> /etc/apt/sources.list.d/cinelerra-ppa-ppa-trusty.list <==
deb http://ppa.launchpad.net/cinelerra-ppa/ppa/ubuntu trusty main
deb-src http://ppa.launchpad.net/cinelerra-ppa/ppa/ubuntu trusty main

==> /etc/apt/sources.list.d/foobnix-team-foobnix-player-trusty.list <==
deb http://ppa.launchpad.net/foobnix-team/foobnix-player/ubuntu trusty main
deb-src http://ppa.launchpad.net/foobnix-team/foobnix-player/ubuntu trusty main

==> /etc/apt/sources.list.d/getdeb.list <==
# deb http://archive.getdeb.net/ubuntu trusty-getdeb apps 

==> /etc/apt/sources.list.d/google-chrome-beta.list <==
### THIS FILE IS AUTOMATICALLY CONFIGURED ###
# You may comment out this entry, but any other modifications may be lost.
deb http://dl.google.com/linux/chrome/deb/ stable main

==> /etc/apt/sources.list.d/google.list <==
deb http://dl.google.com/linux/chrome/deb/ stable main

==> /etc/apt/sources.list.d/jonoomph-openshot-edge-trusty.list <==
deb http://ppa.launchpad.net/jonoomph/openshot-edge/ubuntu trusty main
deb-src http://ppa.launchpad.net/jonoomph/openshot-edge/ubuntu trusty main

==> /etc/apt/sources.list.d/mc3man-trusty-media-trusty.list <==
deb http://ppa.launchpad.net/mc3man/trusty-media/ubuntu trusty main
deb-src http://ppa.launchpad.net/mc3man/trusty-media/ubuntu trusty main

==> /etc/apt/sources.list.d/mongodb-org-3.0.list <==
deb http://repo.mongodb.org/apt/ubuntu trusty/mongodb-org/3.0 multiverse

==> /etc/apt/sources.list.d/official-package-repositories.list <==
deb http://packages.linuxmint.com rosa main upstream import

deb http://extra.linuxmint.com rosa main

deb http://archive.ubuntu.com/ubuntu trusty main restricted universe multiverse
deb http://archive.ubuntu.com/ubuntu trusty-updates main restricted universe multiverse

deb http://security.ubuntu.com/ubuntu/ trusty-security main restricted universe multiverse
deb http://archive.canonical.com/ubuntu/ trusty partner

==> /etc/apt/sources.list.d/openshot_developers-ppa-trusty.list <==
deb http://ppa.launchpad.net/openshot.developers/ppa/ubuntu trusty main
deb-src http://ppa.launchpad.net/openshot.developers/ppa/ubuntu trusty main

==> /etc/apt/sources.list.d/sunab-kdenlive-release-trusty.list <==
deb http://ppa.launchpad.net/sunab/kdenlive-release/ubuntu trusty main
deb-src http://ppa.launchpad.net/sunab/kdenlive-release/ubuntu trusty main
9
  • did you examine /var/log/fontconfig.log as the error message suggested?
    – cas
    Apr 5, 2016 at 1:34
  • @cas i've updated fontconfig.log Apr 5, 2016 at 1:53
  • the last line indicates a problem with fc-cache. show output of ldd /usr/bin/fc-cache. maybe try re-installing fontconfig package and all its dependencies.
    – cas
    Apr 5, 2016 at 1:57
  • @cas whole log? Apr 5, 2016 at 2:13
  • 1
    Looks like you are mixing releases or added repositories designed for other OS releases. Your broken fontconfig appears to be because the API changed but the soname didn't get bumped.
    – jordanm
    Apr 5, 2016 at 2:36

1 Answer 1

0

Try below:

sudo wget http://kr.archive.ubuntu.com/ubuntu/pool/main/f/fontconfig/fontconfig-config_2.11.94-0ubuntu2_all.deb
sudo dpkg -i fontconfig-config_2.11.94-0ubuntu2_all.deb
1
  • While the commands you suggested may answer the question, it is preferred that you explain your answer to some extent. Nov 4, 2016 at 6:36

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .