2

I have udev support in kernel(CONFIG_DEVTMPFS), thus my system does not strictly require udev daemon. Indeed everything works fine without udev daemon with the exception of Xorg (LXDE).

LXDE starts fine, but keyboard and mouse are not working.

A related question on SuperUser suggests I need to modify my /etc/X11/xorg.conf to not use udev, but specify input devices manually.

These are the relevant sections in my /etc/X11/xorg.conf:

Section "InputDevice"
    Identifier  "Keyboard0"
    Driver      "kbd"
EndSection

Section "InputDevice"
    Identifier  "Mouse0"
    Driver      "mouse"
    Option      "Protocol" "auto"
    Option      "Device" "/dev/input/mice"
    Option      "ZAxisMapping" "4 5 6 7"
EndSection

How do I need to change my xorg.conf so that my input devices work ?

2

Add the following section:

Section "ServerLayout"
  Identifier   "Layout[all]"
  InputDevice  "Keyboard0" "CoreKeyboard"
  InputDevice  "Mouse0" "CorePointer"
  Option       "AutoAddDevices" "off"
EndSection

To find the correct mouse and keyboard drivers, I suggest you inspect /var/log/Xorg.0.log before you turn udev off: you will see which driver it selects, and which options it may apply to them.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.