0

I have exactly the same problem as described here. I can find the same "Oops" messages in /var/log/kern.log. I also have an older Radeon HD (so I have to use the free driver). I downloaded the current Debian DVD image, installed it, and my PC is completely unusable, always freezing after a couple of minutes.

So from what I understand, this is a problem with a patch, which is working in newer kernels, and was also applied to older kernels (like 3.16.0-4 — which is used in the Debian 8.3 now) where it causes this horrible bug.

So if I install Ubuntu 16.04 LTS with Linux kernel kernel 4.4, I will not get this bug? Yes or no?

Thanks in advance!

  • 2
    ps: you can always install a newer kernel side by side on your system to run some tests, before upgrading your system. – fduff Apr 4 '16 at 10:10
  • @fduff: Where do I get it? I don't have the patience to compile it myself. – wolf-revo-cats Apr 5 '16 at 4:19
  • My answer included a link to instructions on how to install a separate kernel on Debian using apt-get. – Ryan Apr 5 '16 at 7:28
  • @Ryan: Yeah, I've seen that. The point is where I get the non-buggy version. It seems to be impossible without using an alternative repository. – wolf-revo-cats Apr 8 '16 at 0:12
  • I think you can install 3.16.7-ckt20-1+deb8u4 from the Debian Jessie Updates repository ("deb security.debian.org jessie/updates main contrib non-free" in /etc/apt/sources.list). Have you checked "apt-cache search linux-image"? Or you can install 4.4.6 from jessie-backports, but you'll probably have to configure that. Failing everything else, you could try to download the .debian file manually. – Ryan Apr 8 '16 at 1:30
1

Short answer: Linux kernel 4.4 does not have this bug. You should not run into it on Ubuntu 16.04 LTS.


Detailed answer

If you follow the email chain that you linked, you'll get to this message by Nicolai Hähnle:

Kernels that contain commit 954605ca "drm/radeon: use common fence implementation for fences, v4" are safe, older kernels require a NULL-pointer check around the call to radeon_fence_ref.

Here is the commit he's talking about on kernel.org. For a more useful visual, here is the same commit on GitHub. On the GitHub page, if you expand the list of commit branch and tag labels, you can see that the commit is included in the tag for the 4.4 kernel (see image below), so you should be fine.

Screenshot of GitHub page for Linux kernel commit 954605ca

If you really want to be sure, you can probably boot a LiveCD or USB key running Ubuntu 16.04 LTS (currently still in the beta stage of its release cycle) to test it on your computer.

Edit: It may also be worth noting that Debian 8.3 is no longer the latest version, as Debian 8.4 was released on April 2, 2016. However, Debian 8.4 ships with a kernel where this is still not fixed (3.16.7-ckt25-1). It's important to note that the real thing to look for is not what Linux release you're using, but what kernel you're running. In your case (Debian), kernel 3.16.7-ckt25-1 has this problem while 3.16.7-ckt20-1+deb8u4 and 3.16.7-ckt26 do not (relevant bug report).

Edit 2: You can also, as fduff points out in this comment, install a different kernel version on your existing system. Though, I think that's a bit outside the scope of the question you posed, which was simply, "So if I install Ubuntu 16.04 LTS with Linux kernel kernel 4.4, I will not get this bug? Yes or no?"

  • Debian 8.4 seems to still have this problem. See here. – wolf-revo-cats Apr 4 '16 at 18:08
  • Indeed, it does. That's the same email thread that I linked in my answer. I tried to note that it's not the release version that matters, and that you really need to verify the kernel version. However, rereading my answer, it seems that wasn't made entirely clear. I'll edit my answer. – Ryan Apr 4 '16 at 18:09

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.