1

When I was at Zsh installing Arch Linux, I listed the keymaps ls /usr/share/kbd/keymaps/**/*.map.gz and selected the one for my keyboard loadkeys br-abnt2.map.gz and worked fine there.

After the installing is complete and I startx'd the OS for the first time, I noticed that my keys was unset again. So I ran loadkeys ... again but got an error message that couldn`t find file or something. Then I went there to check and indeed a lot of the folders inside /kbd/keymaps was not added after the installation even after setting the locale correctly.

Then, I searched on the internet and downloaded br-abnt2.kmap.gz (.kmap not .map because I didn't find a .map file for it, I think this won't make difference). Now I'm running loadkeys and having no output but I still can't type using my standard format. I added the kmap.gz to the /usr/share/kbd/keymaps directory already.

So, the question is, how to add new keymaps to system in order to load them correctly? Thanks in advance.

Edit: Just found out that the problem is happening only in gnome interface. If I restart and get in tty the fonts are displayed normally and my keyboard keys are according to my language.

  • 1
    man localectl! – cylgalad Apr 4 '16 at 8:27
0

Perhaps you were looking at this: KEYMAP (Português)

The "tty" (Linux console) keymaps and fonts are separate from GNOME. For that (running in X), this page may help for a start: Can't configure correct keymap for my language

However, the system settings in GNOME are the best place to look, e.g., as in How to change system language?

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.