3
  • Tested with Ubuntu 15.10 and BackBox 4.5.
  • Graphics card i530
  • cpu i7 6700k
  • motherboard used in shuttle xpc sh170r6

I have an issue to scale films to any size with programs like vlc and mplayer. I can play a film but it stays the same size. I can not zoom or scale to full screen. The area around the video is filled with blue or black color.

I experience no problems watching films in a browser(chrome/ffox) (eg. youtube)

Apart from that I experience no graphics issues (2D).

In the Xorg logfile I see nothing that sticks out as an obvious error.

I attach it nonetheless

Has anybody an idea what causes this issue?

TIA

[   417.485] (II) Module vesa: vendor="X.Org Foundation"
[   417.485]    compiled for 1.17.2, module version = 2.3.4
[   417.485]    Module class: X.Org Video Driver
[   417.485]    ABI class: X.Org Video Driver, version 19.0
[   417.485] (II) intel: Driver for Intel(R) Integrated Graphics Chipsets:
    i810, i810-dc100, i810e, i815, i830M, 845G, 854, 852GM/855GM, 865G,
    915G, E7221 (i915), 915GM, 945G, 945GM, 945GME, Pineview GM,
    Pineview G, 965G, G35, 965Q, 946GZ, 965GM, 965GME/GLE, G33, Q35, Q33,
    GM45, 4 Series, G45/G43, Q45/Q43, G41, B43
[   417.485] (II) intel: Driver for Intel(R) HD Graphics: 2000-6000
[   417.485] (II) intel: Driver for Intel(R) Iris(TM) Graphics: 5100, 6100
[   417.485] (II) intel: Driver for Intel(R) Iris(TM) Pro Graphics: 5200, 6200, P6300
[   417.485] (II) modesetting: Driver for Modesetting Kernel Drivers: kms
[   417.485] (II) FBDEV: driver for framebuffer: fbdev
[   417.485] (II) VESA: driver for VESA chipsets: vesa
[   417.485] (++) using VT number 7

[   417.485] (II) intel(0): Using Kernel Mode Setting driver: i915, version 1.6.0 20150522
[   417.485] (II) intel(0): SNA compiled: xserver-xorg-video-intel-lts-wily 2:2.99.917+git20150808-0ubuntu4~trusty2 (Adam Conrad <adconrad@ubuntu.com>)
[   417.485] (II) intel(0): SNA compiled for use with valgrind
[   417.486] (WW) Falling back to old probe method for modesetting
[   417.486] (WW) Falling back to old probe method for fbdev
[   417.486] (II) Loading sub module "fbdevhw"
[   417.486] (II) LoadModule: "fbdevhw"
[   417.486] (II) Loading /usr/lib/xorg/modules/libfbdevhw.so
[   417.486] (II) Module fbdevhw: vendor="X.Org Foundation"
[   417.486]    compiled for 1.17.2, module version = 0.0.2
[   417.486]    ABI class: X.Org Video Driver, version 19.0
[   417.486] (WW) Falling back to old probe method for vesa
[   417.486] (--) intel(0): gen9 engineering sample
[   417.486] (--) intel(0): CPU: x86-64, sse2, sse3, ssse3, sse4.1, sse4.2, avx, avx2; using a maximum of 4 threads
[   417.486] (II) intel(0): Creating default Display subsection in Screen section
    "Default Screen Section" for depth/fbbpp 24/32
[   417.486] (==) intel(0): Depth 24, (--) framebuffer bpp 32
[   417.486] (==) intel(0): RGB weight 888
[   417.486] (==) intel(0): Default visual is TrueColor
[   417.486] (II) intel(0): Output DP1 has no monitor section
[   417.486] (II) intel(0): Enabled output DP1
[   417.486] (II) intel(0): Output HDMI1 has no monitor section
[   417.486] (II) intel(0): Enabled output HDMI1
[   417.486] (II) intel(0): Output DP2 has no monitor section
[   417.486] (II) intel(0): Enabled output DP2
[   417.486] (II) intel(0): Output HDMI2 has no monitor section
[   417.486] (II) intel(0): Enabled output HDMI2
[   417.486] (II) intel(0): Output HDMI3 has no monitor section
[   417.487] (II) intel(0): Enabled output HDMI3
[   417.487] (--) intel(0): Using a maximum size of 256x256 for hardware cursors
[   417.487] (II) intel(0): Output VIRTUAL1 has no monitor section
[   417.487] (II) intel(0): Enabled output VIRTUAL1
[   417.487] (--) intel(0): Output DP2 using initial mode 2560x1440 on pipe 0
[   417.487] (==) intel(0): TearFree disabled
[   417.487] (==) intel(0): DPI set to (96, 96)
[   417.487] (II) Loading sub module "dri2"
[   417.487] (II) LoadModule: "dri2"
[   417.487] (II) Module "dri2" already built-in
[   417.487] (II) Loading sub module "present"
[   417.487] (II) LoadModule: "present"
[   417.487] (II) Module "present" already built-in
[   417.487] (II) UnloadModule: "modesetting"
[   417.487] (II) Unloading modesetting
[   417.487] (II) UnloadModule: "fbdev"
[   417.487] (II) Unloading fbdev
[   417.487] (II) UnloadSubModule: "fbdevhw"
[   417.487] (II) Unloading fbdevhw
[   417.487] (II) UnloadModule: "vesa"
[   417.487] (II) Unloading vesa
[   417.487] (==) Depth 24 pixmap format is 32 bpp
[   417.487] (II) intel(0): SNA initialized with generic backend
[   417.487] (==) intel(0): Backing store enabled
[   417.487] (==) intel(0): Silken mouse enabled
[   417.487] (II) intel(0): HW Cursor enabled
[   417.487] (II) intel(0): RandR 1.2 enabled, ignore the following RandR disabled message.
1

It seems the movie is played via hardware overlay and is not resizable. You can force your player to use the CPU only, not the GPU (no hardware acceleration). This is your browser experience. The video gets resizable for the price of higher CPU load.

  • vlc had acceleration activated. after disabling it, I am now able to resize videos. – murphy Apr 4 '16 at 22:22
2

No need to shut down hardware acceleratio/overlay. In VLC and Gnome MPlayer, under preferences choose x11 as video output module. Ubuntu 16.04, i7 6500U, skylake GT2, Intel HD 520 graphics

  • Doesn't seem to work: mplayer -fs -vo x11 video.mp4 still shows the video in it's original on-screen size/resolution, the rest (most) of the screen remaining black. – Tomislav Nakic-Alfirevic Mar 15 '17 at 13:27

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.