I'm having some serious issues with the network manager in Kali. I have read 25+ other threads / questions with this problem to no avail. Here is what is happening. Essentially the icon is missing from the top and there seems to be no way to open it.

On a Kali Linux live USB (latest stable version of OS) plugged into a Macbook Air, the network manager icon is missing in the corner. Many threads suggest that you "right click and add to panel" to get it back, but I can't right click this-- right-clicking the upper right notifications area does the same thing as left-clicking. There is no option to add anything.

I have tried running NetworkManager at the terminal, and it recognizes the command but does nothing. I have also tried running /etc/init.d/network-manager start after stopping it, and it tells me it is starting it but nothing appears on the screen and nothing changes.

When I go to Settings, the only related area is "Network" which brings up a little window with some proxy options and nothing else. This doesn't seem to be the Network Manager, which is also not listed under Applications.

What is going on here? I don't know what to try next. I have no internet access so I can't download anything.


Here is the output of iwconfig:

lo    no wireless extensions

Here is the output of ifconfig:

lo: flags=73<UP,LOOPBACK,RUNNING> mtu 65536
    inet netmask
    inet6 ::1 prefixlen 128 scopeid 0.10<host>
    loop txqueulen - (Local Loopback)
    RX packets 16 bytes 960 (960.0B)
    RX errors 0 dropped 0 overruns 0 frame 0
    TX packets 16 bytes 960 (960.0B)
    TX errors 0 dropped 0 overruns 0 carrier 0 collisions 0

Here is the output of ipconfig:

bash: ipconfig: command not found

Here is the output of lspci | grep -i network:

03:00.0 Network controller: Broadcom Corporation BCM4360 802.11ac Wireless Network Adapter (rev 03)

Also, service network-manager restart has no output at all. And running nm-applet causes a notification to pop up that reads "Disconnected: The network connection has been disconnected." There is no other result.

  • Run update-pciids and try lspci | grep -i network – GAD3R Apr 3 '16 at 19:14
  • One sec, have to update output of all of those, did something really stupid. Unplugged live usb by accident. Restarting now, assume output will be different. – temporary_user_name Apr 3 '16 at 19:15
  • Okay there we go, updated. – temporary_user_name Apr 3 '16 at 19:19

The issue is very likely a lack of installed drivers for the MacBook Air's network card. NetworkManager tends not to display an applet icon when no networks are available.

Could you list the output of ipconfig, ifconfig, and/or iwconfig? One or more of those commands may not be available by default, but any of them should list a decent amount of your networking information. lspci | grep -i network should also provide some helpful information.

If you give the model and year of the laptop, we should be able to better help you.

  • I'll get back to you with this in the morning. Thanks! – temporary_user_name Apr 3 '16 at 5:35
  • Updated with output of those commands. – temporary_user_name Apr 3 '16 at 19:19
  • @Aerovistae give this link a shot. – Thomas Ramage Apr 3 '16 at 19:41
  • Gee, this whole reputation thing is severely limiting. Commenting here because that's about all I can do. Take the USB drive and boot into it using a computer with internet access, then do the install. – Thomas Ramage Apr 3 '16 at 20:22
  • Oh, you're new to SE! Welcome! You'll have the necessary rep for basic things quick enough if you participate for a few days. And yes, okay, I'll try it out on my PC later tonight when I get home. What were you trying to do other than add a comment here, that you didn't have the rep for? – temporary_user_name Apr 3 '16 at 20:59

Edit sources.list and add the following lines:

# Regular repositories
deb http://http.kali.org/kali sana main non-free contrib
deb http://security.kali.org/kali-security sana/updates main contrib non-free
# Source repositories
deb-src http://http.kali.org/kali sana main non-free contrib
deb-src http://security.kali.org/kali-security sana/updates main contrib non-free

Update apt-get update

install linux-header

apt-get install linux-headers-$(uname -r)

install broadcom-sta-dkms

apt-get install broadcom-sta-dkms

Unload and load driver

sudo modprobe -r b43 bcma
sudo modprobe wl


Mount your Live_usb

Open terminal and type the following command:

dpkg -i /media/Your_username/your_usb/pool/main/d/dkms/dkms_*.deb
dpkg -i /media/Your_username/your_usb/pool/restricted/b/bcmwl/bcmwl-kernel-source_*.deb

Replace Your_username and your_usb with yours.

  • I don't have any internet....can't use apt-get install without internet. – temporary_user_name Apr 3 '16 at 19:49

I found a way that helped.

airmon-ng check kill

service NetworkManager start

And voilà NM is back again

Not the answer you're looking for?Browse other questions tagged or ask your own question.