I was trying to do wifi throttling for my new app development (new to this) and was trying to do it using iceFloor application. I'm not 100% sure if this is a problem, but i need to confirm if i really have messed it up or not.

When i try to ping www.google.com, i get the below.

PING www.google.com ( 56 data bytes
Request timeout for icmp_seq 0
Request timeout for icmp_seq 1
Request timeout for icmp_seq 2
Request timeout for icmp_seq 3
Request timeout for icmp_seq 4
--- www.google.com ping statistics ---
6 packets transmitted, 0 packets received, 100.0% packet loss

But i don't have any problem browsing whatsoever.

Below are the things i did to mess it up:

  1. I did what was told here.
  2. Tried to limit the bandwidth with Network Limit Conditioner as stated here

  3. I installed iceFloor and tried preset profiles and created custom profile with no configuration. (Apparently, didn't save the default configuration)

Below are the things i tried before posting here:

I tried to flush all the rules using the below command

pfctl -f /etc/pf.conf

I tried turned off the the Network Limit conditioner as well.

Will uninstalling iceFloor & network limit conditioner help? Any insight & recommendations are very much appreciated.



I tried uninstalling iceFloor and that resolved the issue. I was skeptical to try it first and hence i have posted this in first place. But it did work.

PING www.google.com ( 56 data bytes
64 bytes from icmp_seq=0 ttl=45 time=155.492 ms
64 bytes from icmp_seq=1 ttl=45 time=129.689 ms
64 bytes from icmp_seq=2 ttl=45 time=129.214 ms
64 bytes from icmp_seq=3 ttl=45 time=120.146 ms
64 bytes from icmp_seq=4 ttl=45 time=87.930 ms
64 bytes from icmp_seq=5 ttl=45 time=26.346 ms
64 bytes from icmp_seq=6 ttl=45 time=27.915 ms
--- www.google.com ping statistics ---
7 packets transmitted, 7 packets received, 0.0% packet loss
round-trip min/avg/max/stddev = 26.346/96.676/155.492/47.674 ms



Looks like you just blocked (some type of) ICMP packages. Especially since you are saying browsing works fine and you can see the DNS resolving works without problems. It is no problem to block ICMP packages, so if everything except ping works fine, you can just leave it that way if you want.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.