1

I've recently bought a hdmi splitter the splitter is inactive, which means only one screen can be active at a time.

It's starting to get frustrating that my tv seems to have a higher priority than the monitor its shared with, and having to switch it off and on again to display. I'd prefer the monitor to have a higher priority and when i want to use the TV i'd simply turn off the monitor or run a script that switches it off. I've tried setting it active again with xrandr

But can't seem to get it to work.

The following is the connected screens

Xrandr --query

Screen 0: minimum 8 x 8, current 5760 x 1080, maximum 16384 x 16384
DVI-I-0 disconnected (normal left inverted right x axis y axis)
DVI-I-1 connected 1920x1080+0+0 (normal left inverted right x axis y axis) 531mm x 299mm
   1920x1080     60.00*+  59.94    50.00    60.00    50.04  
   1680x1050     59.95  
   1440x900      59.89  
   1280x1024     75.02    60.02  
   1280x960      60.00  
   1280x720      60.00    59.94    50.00  
   1024x768      75.03    70.07    60.00  
   800x600       75.00    72.19    60.32    56.25  
   720x576       50.00  
   720x480       59.94  
   640x480       75.00    72.81    59.94    59.93  
HDMI-0 connected 1920x1080+3840+0 (normal left inverted right x axis y axis) 530mm x 290mm
   1280x720      60.00 +  59.94  
   1920x1080     60.00*   60.05  
   1680x1050     59.95  
   1600x900      60.00  
   1280x1024     60.02  
   1280x960      60.00  
   1152x720      60.00  
   1024x768      60.00  
   800x600       60.32  
   720x576       50.00  
   720x480       59.94  
   640x480       59.94    59.93  
DP-0 disconnected (normal left inverted right x axis y axis)
DVI-D-0 connected primary 1920x1080+1920+0 (normal left inverted right x axis y axis) 598mm x 336mm
   1920x1080     60.00*+
   1680x1050     59.95  
   1440x900      74.98    59.89  
   1280x1024     75.02    60.02  
   1024x768      75.03    60.00  
   800x600       75.00    60.32  
   640x480       75.00    72.81    59.94  
DP-1 disconnected (normal left inverted right x axis y axis)

HDMI-0 is the connected TV and i believe that DVI-I-0 is the disconnected monitor i'm trying to activate.

I've tried switching it on by running xrandr --output DVI-I-0 --auto

Without success, all i seem to be able to do is make the screens flicker when calling calling xrandr --output HDMI-0 --auto with the TV as output.

  • Are you sure it is not one of the two outgoing connectors of the splitter that has the priority? – Anthon Apr 1 '16 at 16:19
  • First signal first serve sort of thing you mean? – JazzCat Apr 1 '16 at 16:22
  • I'd guess that the splitter only shows up as one device to the computer, and the splitter determines which display gets the picture... But I'm not sure. If you disconnect the splitter, does that port go away? – derobert Apr 1 '16 at 16:51

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.