1

I use Ubuntu Linux 14.04 LTS. My all-in-one scanner and printer worked well with xsane 0.998 until I upgraded the hplip driver 3.16.2. This resulted in a number of inconveniences (for example, one other post on AskUbuntu).

Concerning the scanner, after upgrading the driver and attempting to scan a document, I was then presented with a dialogue that asked me to choose between two options. This request seemed unusual to me since I can't recall to have faced it in previous hplip upgrades. I inadvertently chose for what appeared to me the most appropriate selection, but this proved me wrong. Unfortunately I cannot recall much more details about this incident.

Ever since, as I try to start the scanner GUI, I am presented with the following error dialogue:

Error dialogue Xsane when starting

My perceptions about the points raised there are: 1. It may well be now, but wasn't certainly so earlier. 2. Not applicable, the device is nice and ready. 3. It never has been the case earlier as I always worked through the GUI. 4. Unclear 5. Unclear 6. I haven't installed any more version of SANE

Whatever the reason is, could someone please guide me through the process of finding the cause for trouble and fixing it. My objective would be to restore the functionalities prior to this upgrade. Thanks in advance.

Added This issue seems to be also linked to greater problems with hplip that I have raised in this other post hplip 3.16.2: no installed HP device found (while CUPS finds it)

1

http://support.brother.com/g/s/id/linux/en/faq_scn.html?c=us_ot&lang=en&comple=on&redirect=on

This link is to a (possibly "the") solution for brother multi-function printer's scanner access issues. Perhaps there is a similar thing to do for HP multi-function printers.

  • 1
    It is better if you include at least the most relevant part of the remote content to your answer, it is because links tend to rot in the years, but your answer should remain understable until the eternity. Although in your case it is not very clear to me, how could it be done without copy-pasting the whole remote content. – peterh Sep 5 '17 at 6:21
0

I did a fresh install of Ubuntu 16.04.3 and I get the same response. My Brother MFC-J615W is connected to a router (networked).

I remember somewhere (and for what I can't remember) that there are some lib64 files that needed to be copied to lib and lib32 directories. This possibly might be the answer that we're looking for.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.